1. Peitso's Avatar
    I'm using the latest version of "CNN Breaking US & World News" -app on Android downloaded from Google Play. The device I'm using is LG V30+ running Android 7.1.2 with latest security patches.

    Otherwise the app works just fine, but I'm unable to receive any notifications from the app. So far I've tried the different notification customizing options the app has built-in (including turning silent hours on and off and changing the density of news notifications per day). I've also deleted the cache and data of the app from the system settings and deleted and reinstalled the app quite a few times now. I've also restarted the phone multiple times and checked that the CNN app has proper notification permissions in system settings (and that the notifications aren't blocked or anything) and that no battery optimization is turned on for the app.

    Other apps that I've installed on my phone are displaying their notifications just fine including CNN MoneyStream app that I've also installed. The CNN main app also displays notifications currently on my two other devices (my older Nexus 6P and iPhone 6s Plus). I'm also not using battery saving mode or "do not disturb".

    The only other troubleshooting option left to do that I can think of is complete factory reset of the phone and/or wiping the whole cache partition clean. Since my phone is otherwise working very smoothly and there are no other issues at the moment I'm not willing to go there just yet. From previous experiences with Nexus 6P I've learned that sometimes wiping the whole cache partition can cause similar problems with other apps. Sometimes simply reinstalling the misbehaving app and deleting its cache can help, but that doesn't seem to be the case this time.

    Before doing the most recent factory reset on my LG V30+ I wasn't receiving any notifications from AP Mobile (which now works) and BuzzFeed News (working as well) so this issue isn't necessarily tied to the CNN app, but is probably a larger problem with the way notifications on Android work. I've also tested the push notifications with a tester app and it works just as it should.

    I recently did a factory reset because I was experiencing serious notification delays on my device. Some apps like Twitter displayed notifications with a delay of 30 minutes to 2 hours. Now all the other apps that I've installed are showing their notifications right on time (at the same moment with my iPhone 6s Plus and Nexus 6P).

    So I'm asking you are you aware of any compatibility problems with the CNN app at the moment or is there anything else I could do to make the app show notifications correctly. It's a great app so it's really a shame that the notifications aren't displayed at all on my newest Android device. Of course I can use the widget for CNN, but it's just not the same. I've also emailed CNN app support about this issue, but they haven't replied yet.

    EDIT. Just checked the running services from developer settings. CNN is using constantly over 200 MB of RAM on my LG V30+ (where the push notifications for it aren't working at all) and on my Nexus 6P (where the app works just as it should) just about 20 MB. So there's a significant difference there. On my Nexus 6P there's also an additional process for CNN running (com.android.chrome:sandboxed_process0) consuming 2 MB of RAM. The aforementioned process isn't running at all on my LG V30+.
    11-07-2017 08:50 AM
  2. Rukbat's Avatar
    The same version of CNN on both?

    Try (on the one that isn't working) Settings/General/Apps, find the CNN app and tap Clear Cache. (That doesn't delete any of your data.) Also boot into recovery and use Wipe Cache (careful - only Wipe Cache). Then see if it clears up.
    11-07-2017 02:54 PM
  3. Peitso's Avatar
    Yeah, both of them are running the latest and greatest version 5.8.1 of CNN app. Previous versions of the app have the exact same problem (I sideloaded two previous versions of the app to test it). As I mentioned I've cleared the cache for the CNN app already a few times, and deleted all app data, and reinstalled the whole app.

    Booting into recovery and wiping cache is the logical next step. The issue here is that the CNN app is pretty much the only app I've installed and regularly use that's not showing push notifications at the moment and usually wiping cache partition causes some other apps to stop showing push notifications (according to my previous experiences with Nexus 6P). It's really a shame that one app has to misbehave like this now. Something's preventing the CNN from displaying push notifications (it might be something in the cache partition).
    11-07-2017 03:08 PM
  4. Peitso's Avatar
    Okay, so I tried to access the recovery mode on my LG V30+ by following these instructions:
    "Turn Off Your device.
    Now Press and Hold Volume Down+Power button for 2-3 Seconds Until LG Logo Appears.
    Release the Buttons And Press and Hold them Again.
    Hold the Buttons until the Recovery Mode Screen Appears.
    Now You Are in the Recovery mode of Your device."
    If I follow those aforementioned steps the LG logo just keeps popping after a black screen continuously. Now if I release only the power button for a second while holding the volume down button I'm able to access a factory data reset -menu. The only option here is to delete all user data (factory reset). There's no option for wiping the cache partition or anything else.


    This video shows the aforementioned process in YouTube

    Usually recovery mode can be accessed like that on most of the Android devices. Even older LG devices were able to access recovery mode that way. However, I believe that starting with LG G6 fully-functional recovery can't be accessed with a key combination and only via ADB command (adb reboot recovery). Even then the recovery mode is severely stripped-down (basically useless) because it doesn't show different actions to choose from.


    This video shows what I'm talking about, the device used in video is LG G6 but I tried that with my own LG V30+ and the results are exactly the same.

    Now there might be differences between models from different regions (I believe that was the case with at least LG V20 because some regional variants didn't have the access to the recovery mode or fastboot mode) so maybe my South Korean LG V30+ has this limitation and some other versions of V30 or V30+ don't have this same limitation.
    11-08-2017 07:38 AM
  5. Rukbat's Avatar
    Yes, I'm aware of that with newer LGs - I have a V20. I haven't yet installed TWRP, because I want to make sure I can get back to normal if something goes wrong. (As for versions, my US [T-Mobile] version has the same "no real recovery" problem.)
    11-08-2017 03:24 PM

Similar Threads

  1. Gaming on the E4
    By erwaso in forum Moto E
    Replies: 7
    Last Post: 11-17-2017, 08:07 PM
  2. Google Play download manager wont update to Android Oreo
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 11-09-2017, 06:08 PM
  3. Experia L1. All the notifications are silenced,how can i unsilence them
    By Littlenic79 in forum General Help and How To
    Replies: 1
    Last Post: 11-07-2017, 11:47 PM
  4. Replies: 1
    Last Post: 11-07-2017, 03:00 PM
  5. Can't see all emojis on Samsung s6
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-07-2017, 02:57 PM
LINK TO POST COPIED TO CLIPBOARD