1. Android Central Question's Avatar
    I have at least one wi-fi saved which "requires" that one agree to their terms (it's my local gov; the only "terms" I should by which I should be bound are the laws of the land), but there are some sites that it doesn't redirect you to their sign-in page and I use it when I'm taking the bus, or sometimes a bus will drive by when I have wi-fi on and forgot to Forget it and it'll pop up a demand to sign in, INTERFERING WITH WHAT I'M ALREADY DOING; if I'm recording a video or typing something, it stops it in order to make this demand. I want it to STOP.

    I've looked at a couple of the permissions and the wi-fi management one from LG has it -- I guess it's called "Draw Over," but we've all been around the internet enough to know a pop-up when we see one -- but it seems to borrow that permission from some other application. (Sorry; I forget what they're all called, and the battery is presently out of the device for charging.)

    I'm not sure, but I may be able to remove that permission by "downloading" the .apk via Firefox, then reinstall using APK Permission Remover. Probably it will say the old one has to be uninstalled first, then when I say 'okay,' it tries and the uninstallation fails, but I'm willing to try, so does anybody know what application has that permission? Maybe another permission remover... I'll look around for one in the meantime.

    Barring all that, HTF can I get rid of these pop-ups (yes, yes; 'root your phone,' I know). I don't care that I get a notice in the Status Bar saying to sign in (and that's what Disable Notifications does); that doesn't interfere with my work/play.

    I'm on an LG Optimus Exceed 2 running KitKat, 4.4.2.
    12-07-2017 04:44 PM
  2. Dano1200r's Avatar
    Go to Settings, Connections, WiFi, Advanced, And UNCHECK Network Notification.
    12-07-2017 09:23 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Wi-fi, and look for an option to Connect to Open Networks automatically, or to notify you about open networks nearby. Turn those off. (You might have to tap the Menu button while in the Settings>Wi-fi menu in order to access Advanced Wi-fi settings.)

    I agree that the only terms you should be bound by to live your life in your country are the laws of the land -- but in any market-based society, using any service provided by a non-governmental entity can still depend on more specific terms and conditions set up by that entity. If you don't agree to it, you don't have to use that service.
    Laura Knotek likes this.
    12-08-2017 04:04 PM
  4. Android Central Question's Avatar
    Well, I'm posting this again because the site won't let me register to reply to the answered, previous post. I fill out the info and click to sign up and get a text page reading, "[well, your servers seem to think the code is spam, so I can't post it]" I see something about a CAPTCHA phrase, but wasn't given one; again, cannot post a screenshot.

    __________________

    [okay, or maybe they think reposting the message is spammy, so you'll have to go look it up.]

    __________________

    The posted answer was to go to Settings > Wi-FI > Advanced > Disable Notifications.

    Okay, that does seem to do it, but it disables ALL notifications, including really useful ones in my Status Bar and Notifications Drop-down, like what network it's connected to, if it drops/there are networks available, etc. If I'm on my browser and the network's one I have to sign in to, like the mentioned, and it's switched from one that I didn't without my knowledge (because, notifications disabled), then it's going to send me to that page next and I won't be able to back out; it often just eliminates my page history, loses any info I was sending, destination page, etc.

    So... can I get rid of just the pop-up, remove the permission from whatever application is using it or, again, sharing it with another?
    12-08-2017 04:33 PM
  5. belodion's Avatar
    I've merged your threads as a temporary fix. Stand by for advice about registering successfully.
    12-08-2017 05:01 PM
  6. B. Diddy's Avatar
    I actually suggested looking for a couple of specific options: "Connect to Open Networks" and "Notify About Open Networks." These should be very specific, and not turn off every single notification having to do with wi-fi. Not all phones will have these options -- tell us which options you see in your Advanced Wi-fi menu.

    The forums software has been pretty temperamental off and on. Are you trying to register on your desktop browser or mobile browser? Try using the desktop browser, and do so in Incognito Mode, in case any browser extensions are interfering.
    belodion likes this.
    12-09-2017 12:25 AM
  7. Android Central Question's Avatar
    I'm registering on desktop, and just tried on mobile, in Private Browsing, but get the same message/glitch. (Edit: I'll try registering with all add-ons disabled, but that'll require restarting, of course, so pardon if I don't want to lose what I already typed below and do that later.)

    I posted the original question twice, this one when my phone was unavailable, and then again soon after when it was, listing those other applications that Mobile Hotspot UI shares permissions. A note on that one that unchecking Wi-Fi Notifications under Advanced actually doesn't work; it just turns off all the Status Bar and Notifications drop-down stuff, and still allows the pop-ups.

    To this answer, I don't have Connect... Automatically or Notify of Open Networks. That first one may be nice, but I suspect it would be asking me if I want to sign in via a pop-up. :S

    Under Settings > Wi-FI, I have Show Wi-FI pop-up – WAIT! – that says, "When opening apps, tell me when wi-fi is available," and it's been long unchecked.

    From my Menu options, I have:

    • WPS Push Button
    • WPS Pin Entry
    • Add network
    • Wi-Fi Direct
    • Advanced Wi-Fi
    - Notifications -
    • Wi-Fi Notifications [doesn't do it, as noted above]
    • Internet Unavailable (Disconnect wi-fi automatically when the Internet is unavailable)
    - List -
    • Sort list by... (Alphabetical order)
    - Optimization -
    • Manage Networks (Drag a network to specify the order in which it will be detected) [I've tried rearranging this so the problem one is last, but sometimes it may be the only one, and something also keeps reordering them from what I specify, which is another question I'll post later]
    • Keep wi-fi on during sleep
    • Scanning always available
    • Wi-Fi signal weak
    • Battery saving for wi-fi
    - Personal -
    • Install certificates
    - Information -
    • MAC address
    • IP address
    • Help
    12-09-2017 02:55 PM
  8. belodion's Avatar
    Threads merged again.
    12-09-2017 06:12 PM
  9. B. Diddy's Avatar
    It's strange that it only gives you the option to turn off all wi-fi notifications. Do you have any wi-fi manager apps installed, perhaps from LG or your carrier?

    Also, when you see that popup notification -- is it also in the swipedown notification panel? If so, long-press it and tap App Info.

    Definitely try registering on desktop Chrome in Incognito Mode. If you're still having problems, send a message here to see if someone behind the scenes can help: https://forums.androidcentral.com/sendmessage.php
    12-10-2017 04:37 PM

Similar Threads

  1. S8 Voice To Text.....
    By SWL3600 in forum Samsung Galaxy S8 & S8+
    Replies: 2
    Last Post: 12-09-2017, 08:36 PM
  2. Root to get hot spot???
    By KevinWood44 in forum Samsung Galaxy Note 8
    Replies: 5
    Last Post: 12-07-2017, 08:21 PM
  3. my lg4 is stuck in bootloop
    By Sadair67 in forum Ask a Question
    Replies: 2
    Last Post: 12-07-2017, 08:18 PM
  4. Is there a way to uninstall updates?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-07-2017, 06:08 PM
  5. any good widget to adjust sound volumes
    By andrew_sc_syd in forum Huawei Mate 9
    Replies: 1
    Last Post: 12-07-2017, 05:33 PM
LINK TO POST COPIED TO CLIPBOARD