1. Android Central Question's Avatar
    Hi, for a long time I have used the Mail app that came with my Samsung Tab A tablet when sending emails in Gmail but after using the app earlier today without a problem I now cannot send anything. Google displays a message saying it is an insecure app.

    Should I be worried, and if not, how can I get it to work as before.

    Any replies will be welcome, thanks,

    Roger
    01-05-2018 04:23 AM
  2. Tim1954's Avatar
    Are you sure it's Google saying that? Does this popup tell you to download anything or click on anything? A screenshot would be handy here...
    Go to settings... Apps... Find the mail client and force stop it. Wipe its cache. Reboot.
    Repeat with Gmail...
    01-05-2018 07:40 AM
  3. rogerbid's Avatar
    Hello Tim1954
    Thanks so much for your reply.

    To be honest, I am not sure exactly what is going on!! I think I am right in saying that the app I am using is one that was originally on the tablet when purchased, but cannot now be 100% certain. To help you identify the app I am attaching a picture of the icon on the Home screen, and the version number shown in App Info.

    I am also attaching the notification I got from Google.

    It is strange that today I have received emails in this app as normal but it will not send anything. I have tried several times to send emails to myself and they do not go!

    I am able to use my Gmail account with the Gmail app so will do nothing until I hear back from you. I do not know how to 'wipe its cache' and I am not sure what you mean by 'Repeat with Gmail' so can you explain a little more please? Thanks.

    I am wondering if I should have posted this in the Tab A forum, sorry if I have made a mistake!

    Thanks for your help,

    Roger
    Attached Thumbnails Has Google decided Mail app is unsafe-google.jpg   Has Google decided Mail app is unsafe-icon.jpg   Has Google decided Mail app is unsafe-version.jpg  
    01-06-2018 12:27 AM
  4. Mooncatt's Avatar
    It looks like you have two issues going on here.

    The first is your email app is not a Google app, so it won't be up to Google's standards. That doesn't mean the app is bad, but it will trigger that notice. All it's doing is alerting you to the unexpected sign in attempt from a non-Google client. For this, follow the link it gave you to allow access by less secure apps. That should get that situation resolved.

    If this doesn't also fix the issue with sending emails, then you may also have an issue with your email app settings. I remember when I used a similar OEM email app to access my Yahoo account, I had to manually set things up so it could properly talk to the Yahoo servers. I think it was the Pop3 settings, or something like that. Unfortunately I'm not sure what steps you'll need to take to get your settings right if that's the issue.
    Tim1954 likes this.
    01-06-2018 12:58 AM
  5. rogerbid's Avatar
    Hi Mooncatt, thanks for your reply.

    I am reluctant to select 'allow accessby less secure apps' because it seems it is a blanket permission, I cannot single out this 1 app.

    It is interesting that for many months the app has worked well and my wife still continues to use the app on her Tab A without any issues. I think if I cannot find a solution without granting this far reaching permission I will stop using this app!

    As emails are still arriving in my inbox with this app I might see if I can restore the settings as you suggest.

    Thanks for your help,

    Roger
    01-06-2018 01:06 AM
  6. Tim1954's Avatar
    It is as Mooncatt said.
    Is still worthwhile doing the app resets though..
    I don't have that email client in my device, so I used words with friends app but the principle is the same. Open settings... Apps... Find email (it may be in system apps)... Once you open that, you will see "memory"... Tap that and it gives you data and cache use. Under cache tap "clear". Go back one step with your right side soft key, tap "force stop". Close everything using "recents" button. Open them again and see if that works. If this doesn't help, you can repeat steps and clear "data" as well. This means you will have to sign into your email again...
    See the attached screenshots...
    Attached Thumbnails Has Google decided Mail app is unsafe-screenshot_20180106-174017.jpg   Has Google decided Mail app is unsafe-screenshot_20180106-174034.jpg   Has Google decided Mail app is unsafe-screenshot_20180106-174053.jpg  
    01-06-2018 02:32 AM
  7. rogerbid's Avatar
    Hello again, and thank you for your assistance. I will do as you suggest tomorrow and report back on the result. Best wishes and my thanks,
    Roger
    01-06-2018 02:57 AM
  8. rogerbid's Avatar
    Hi,

    Thanks very much, your suggestion has achieved the desired result - I had to clear data as well as the cache, and restart the app entering the Gmail account I wanted to use. I sent myself a test email and it went immediately. So far I have not received any communication from Google suggesting the app was 'less secure'

    Thanks again to you both for your help, best regards,

    Roger
    01-07-2018 02:30 AM

Similar Threads

  1. Why is my facebook messenger app not receiving calls?
    By Android Central Question in forum Android Apps
    Replies: 1
    Last Post: 04-09-2018, 06:29 AM
  2. Switching apps taking >7seconds
    By Android Central Question in forum Samsung Galaxy S8 & S8+
    Replies: 8
    Last Post: 01-19-2018, 12:18 AM
  3. My HTC one E9S won't turn on/ black screen and it has a solid green LED light
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-05-2018, 05:48 AM
  4. My vivo s7i is stuck on startup screen
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-05-2018, 02:36 AM
LINK TO POST COPIED TO CLIPBOARD