1. Android Central Question's Avatar
    I have a mate 10 pro. And i have problems using the Bluetooth with my "m810pro"
    I can connect to every unit with BT and use the BT features such as talking over the phone, listing to music and so on. But after a few minutes the voice channel switches from the BT unit, lets say a speaker, to my phone.

    So the scenario is:
    I connect my mate 10 pro to a BT speaker, and i listen to music for a short time, and suddenly, the music is playing from my phone and not the BT speaker.
    This scenario has happen many times with several different speakers.
    The phone is still connected but the music is playing from my phone.

    I called the huawei support, and he gave me a short answer:
    "The phone may not be compatible with the bt unit"
    But then funny part for me is,
    I can connect to every unit, play from every unit, and talk with the BT. But the problem with the sound channel switching is everytime. And first, after a few moments.

    Anybody had similar experience or know what to do?
    01-16-2018 09:55 AM
  2. Rukbat's Avatar
    As they said, the phone may not be compatible with the Bluetooth units. (What they didn't go on to say was, "because we may have implemented Bluetooth incorrectly".) It's in warranty, so bring it in for repair or replace.
    01-16-2018 02:40 PM
  3. Lahara's Avatar
    I have the same problem with a Babyalarm (Nabby) using Bluetooth. Usually it loses the connection after approx. 10 minutes. When I realized there was a pattern to it, I also realized that the wifi was doing the same. So after approx. 10 min, the wifi loses the connection to e.g. my chromecast. The connection is only lost if the screen is left turned off.
    When I talked to Huawei's support, the told me to remove Bluetooth devices etc., if that would not solve the issue then a factory reset might. Did all of it, nothing worked.
    Then they told me to send the phone for repair, so I did so. I will get it back soon and will post the result in here.

    But I suspect it is actually a software/firmware issue, with the power optimization being to aggressive, shutting off the radios (Bluetooth and wifi) to conserve power.
    01-17-2018 04:42 AM
  4. Gustav Olav Lundby's Avatar
    I have a slightly different problem. My logitech mini keyboard/pad combo which I for years have beed using with older androids, does not work when connected to my Mate 10 pro with OREO. It correctly asks for and accepts a pin code, but does nothing. The red connect light on the keyboard goes on blinking like the connection did not go throug.

    Trying with the USB C to dongle, works, but occupies the C port.
    01-17-2018 12:11 PM
  5. Lahara's Avatar
    An update on the phone repair. As expected they didn't fix a thing.
    01-23-2018 10:11 AM
  6. nezing's Avatar
    I also had bluetooth conntion problems with my Huawei Mate 10 Pro 10 connecting to bluetooth.Have turned off the phone BT speaker connection.Have a pair of Sony WF 1000 X headphones.Downloaded the Sony bluetooth app.Paired headphones using NFC "touch".Works fine for me
    03-26-2018 05:24 AM
  7. dov1978's Avatar
    So weird. I've had no issues with my Mate 10 Pro Bluetooth until today when it did this very thing twice within the last hour. Music just stopped playing through my work van stereo and played through the phone speakers instead despite it still showing as paired on the stereo. It's never ever done that before. I rebooted the phone and so far so good.
    03-26-2018 06:05 AM
  8. Mik84d's Avatar
    Try disabling Bluetooth location scanning. I did this last night and now Bluetooth appears to be working

    Edit: turned off Bluetooth Scanning in scanning services
    03-27-2018 03:54 PM
  9. dov1978's Avatar
    Try disabling Bluetooth location scanning. I did this last night and now Bluetooth appears to be working

    Edit: turned off Bluetooth Scanning in scanning services
    Just turned mine off. You might be onto something there because I only turned that on last week when I was prompted and I had no issues before that.
    03-27-2018 04:04 PM
  10. Mik84d's Avatar
    Hopefully... It has been annoying me for a week now.
    03-27-2018 05:04 PM
  11. EdKi1's Avatar
    Emailed Huwawei Regarding this, They recommend to reset the device to its original factory default setting, especially after a major update, as this removes all miscellaneous files leftover from the update, and stabilizes the phone performance.

    Worked for me 2 days ok so far. Just make sure to backup everything.
    04-03-2018 08:43 PM
  12. hrtobbe's Avatar
    This can't be true - that you should put your phone back to original factory default settings. There must be some other way to fix this problem.

    I experience it as well all the time. I can't connect to different BT-devices. Sometimes when I finally get to connect it keeps failing. And the most annoying part is that it never connects automatically to any device.

    I have tried everything on my brand new Mate 10 Pro - turning off the BT-connection. Restarting the phone. Deleting BT-devices on my phone and on the device I am trying to connect to. Setting to flight mode and back. Turned off the scannning-thing. Nothing works!

    Does anyone has a solution that will work - and by work I don't just mean for a day or two but forever. It seems we are quite a few people with the same issue here so I guess Huawei is aware about the issue...?
    04-04-2018 10:47 AM
  13. shreyashmalani's Avatar
    I also have a few issues with my Bluetooth. If I connect to my car via android auto Bluetooth works fine and music streams as well. I note car is android auto compatible. But if I am nt connect to the car Bluetooth through android auto media doesn't play through the car stereo.. When you go into Bluetooth settings and check for the click on the information icon next to the car name I observed media was turned off. The so I turned it on but it switches off after few seconds. On doing a device restart all works fine.

    Edit: when I told my friend with a pixel 2 he said it was an issue on oreo as he also had something similar. So I am guessing 8.1 should solve the problem
    04-10-2018 12:44 PM
  14. critta71's Avatar
    I'm Still stuck with this bluetooth issue.. if anyone can help..
    I cannot connect to my car Bluetooth as my car gives a 4 digit pin and the android connection wont active the OK button until i put in 16 digits.. 0000000000000000 obviously not all zeros but thats whats its looking for 16 digits. then the ok is active naturally the pin is incorrect.

    Can anyone suggest a fix for this..
    I have a huawei mate 10 pro running oreo 8.0. Apparently 8.1 update may fix this.. But i cannot get an answer on how much longer before this update or even a patch for this will be issued.
    If anyone has experienced this and has a fix would be greatly appreciated.
    04-12-2018 12:17 AM
  15. dov1978's Avatar
    I'm Still stuck with this bluetooth issue.. if anyone can help..
    I cannot connect to my car Bluetooth as my car gives a 4 digit pin and the android connection wont active the OK button until i put in 16 digits.. 0000000000000000 obviously not all zeros but thats whats its looking for 16 digits. then the ok is active naturally the pin is incorrect.

    Can anyone suggest a fix for this..
    I have a huawei mate 10 pro running oreo 8.0. Apparently 8.1 update may fix this.. But i cannot get an answer on how much longer before this update or even a patch for this will be issued.
    If anyone has experienced this and has a fix would be greatly appreciated.
    I don't even understand why that is happening tbh. I paired my Mate 10 Pro to another car yesterday and had zero issues and it required a 4 digit pin too that worked fine
    04-12-2018 12:43 AM
  16. critta71's Avatar
    Well You wont believe this.. ha as I don't But I have just had my car serviced and they had to reset a couple of modules on the car and updated something and literally 10 minutes ago I picked it up and its working. I guess thats the joys of modern technology. But I am as happy as a pig in yeh well you know... Its working... I just have to now find an app that is well suited to using in the car. If anyone can help with that. much appreciated..
    It does make me wonder why my model phone seemed to be the only one with the issue. latest iphone no issue.. I connect with mates s9 yesterday no issue.. so not sure why i did have the problem.. but woohoo
    dov1978 and shreyashmalani like this.
    04-12-2018 01:52 AM
  17. Eric Ghosh's Avatar
    Any one has solution for Huawei mate 10 Bluetooth problem ?
    06-20-2018 06:44 PM
  18. critta71's Avatar
    Whats your issue?
    07-08-2018 10:16 PM
  19. elcustardo's Avatar
    Try disabling Bluetooth location scanning. I did this last night and now Bluetooth appears to be working

    Edit: turned off Bluetooth Scanning in scanning services
    Many thanks. My phone suddenly started dropping connection with my Parrot mki9100. This fixed it.
    01-29-2019 07:20 AM

Similar Threads

  1. Huawei P9 battery goes from 40-50% to 0% and shuts down
    By Android Central Question in forum Huawei P9 & P9 Plus
    Replies: 17
    Last Post: 05-24-2019, 06:30 AM
  2. Motorola E4 Plus call problem
    By ParadoxChils in forum Moto E4 & E4 Plus
    Replies: 4
    Last Post: 05-14-2018, 10:59 PM
  3. OneNote login problem
    By tpapictures in forum Microsoft Apps on Android
    Replies: 17
    Last Post: 03-05-2018, 04:48 AM
  4. Replies: 1
    Last Post: 01-16-2018, 12:22 PM
  5. My Galaxy C9 pro's screen has got blank and showing a blue light
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-16-2018, 09:39 AM
LINK TO POST COPIED TO CLIPBOARD