1. Android Central Question's Avatar
    Ok, so this is for my wife's phone. She has an unlocked GSM Moto G3 with Marshmallow (don't have it in front of me right now, forgot to get the exact OS version). Well, she's suffering from what appears to be a somewhat common problem. So common it has happened to her phone before, and the solutions given online worked before.

    Basically, her phone no longer locks, the home and other apps buttons do nothing, only the back button works, and no notifications or anything else shows up on the top notification tray/drawer.

    So apparently the cause of the problem is that during a system update, the phone basically thinks it has not completed the initial setup yet, so it's stuck at a state where it locks everything else out to force you to complete the initial setup. There are three solutions to this. In order from easiest to most difficult, first is to download and install Nova Launcher, add a widget for an "Activity" and select the setupwizardtestactivity. Run it, go through the prompts, and then everything would work. Second solution is to enable developer options on the phone, enable USB debugging, and then on your PC, install the Android Debug Bridge (adb). Plug the phone to the computer using a USB cable, select yes to enabling USB debugging mode, run adb, and there's a command line to initiate that setup wizard to fix the issue. Lastly, is a factor reset. This is what I'm trying to avoid.

    So here's my issue. First I tried the Nova method like I did before (which fixed it before), but this time, everytime I try to add that activity and run it, it would say "app not installed." I've tried downloading and installing the setup wizard app made by google from places like apk mirror, nothing works. So the first method doesn't work. Then when I try to open Developer Options it gives me the error that it's not available for this user. And just to see if maybe by some luck USB debugging is already turned on, I plugged the phone into the PC. It doesn't even recognize it and simply starts charging... So using adb is out now too. I even just for the heck of it tried the adb devices command to see if it'll show it as a connected device, no dice...

    So, that basically leaves me only with doing a factory reset. Does anyone know of any other way? I've tried searching high and low on the internet and couldn't find a solution to this weird problem...
    01-17-2018 10:49 PM

Similar Threads

  1. Why Is The Pro 12 Tablet So AWFUL!?
    By Miss Misanthropist in forum General Help and How To
    Replies: 8
    Last Post: 01-30-2018, 09:01 AM
  2. Replies: 2
    Last Post: 01-17-2018, 10:08 PM
  3. how long do u charge the new infinix hot 4 pro for the first time ?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-17-2018, 09:46 PM
  4. My Wireless Earbuds start Google Instead of changing song.
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-17-2018, 09:40 PM
  5. How can I disable the square with the red/green arrow next to my texts?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-17-2018, 09:39 PM
LINK TO POST COPIED TO CLIPBOARD