1. Android Central Question's Avatar
    Hello, so here the story:

    My daughter dropped her phone (Samsung Galaxy Ace 2x) on the concrete and broke the glass (digitizer), the image was alright, she could turn off/on the phone, but couldn't do anything else, so she bought another phone, transferred the data, turn off the phone, took off the battery and sim card and let it on the shelf for 2 years.

    (so 2 years later...) I put the battery back. When on the charger I saw the battery logo but no percentage, couldn't turn it on either, thinking it was just the battery that was dead I ordered a new one and changed the digitizer meanwhile (because I really have nothing to do). So now I have a new battery, new digitizer, but same problem! On the charger I see the battery logo that seems to charge but no percentage and I can't turn it on. Look totally dead, no vibration, no light, nothing, the only time I see "something" (battery logo) it's when it's on the charger (which is brand new btw). I tried to press all buttons, plugged it to the computer, nothing... Although it still worked before she transferred the data and put it on the shelve. Any ideas?

    Thanks.
    02-06-2018 01:19 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! I assume you've left it charging undisturbed for at least 6 hours, right? A drained battery can take a little while before it starts registering any charge.

    If it still doesn't charge after many hours, then maybe the USB port got damaged, either in the original fall or in the process of replacing the digitizer.
    02-06-2018 01:46 AM
  3. f88gt6's Avatar
    I let it charge for 2 hours, I see the logo of the battery charging (just not the percentage)
    but I see the battery getting full. The problem is exactly the same as before I changed the the digitizer so I would think, that one didn't cause that specific problem.

    According to my daughter she couldn't see her phone plugged on the computer with the usb before the fall but had no problem charging it. So there might be a problem with the port although it seems to charge anyway. I also thought about the power button, but she said it works even after the fall.
    02-06-2018 02:52 AM
  4. B. Diddy's Avatar
    What do you mean that you saw the battery getting full? Are you talking about the charging animation, where you see the battery icon repeatedly filling up? If so, let it charge for longer than 2 hours (sometimes you have to let it charge overnight). Also, just because you see the battery charging animation doesn't necessarily mean that the battery is charging properly -- maybe there's just a trickle flowing through, which would still result in the animation.

    You're right, the USB port could still be the problem as well. The fact that it was having issues with data transfer prior to the fall might indicate that it was already partially damaged, and the fall might have damaged it further, affecting the charging function.
    02-06-2018 10:49 AM
  5. f88gt6's Avatar
    Yes, it's the animation that shows a battery slowly filling up, meaning that it looks empty when I plugged it and full after 2 hours. I also thought it could be wrong, so I tested the battery with a multimeter and got 4.27 for a battery of 3.8 volt.
    02-06-2018 05:19 PM
  6. f88gt6's Avatar
    I downloaded fonepaw while the phone was plugged to the computer and it suddenly started working before I did anything...Mystery...
    I had tried kies before that without success.
    So the problem is solved now and the digitalizer works well, thanks for helping.
    B. Diddy likes this.
    02-06-2018 09:06 PM
  7. B. Diddy's Avatar
    Wow, good for you! I have no idea what FonePaw might have done, but I'm glad it worked.
    02-06-2018 10:55 PM
  8. f88gt6's Avatar
    Got another problem, maybe I should start another thread? The wi-fi suddenly disappears while kies installed drivers, I tried several things (upgrade), lost patience, factory reset...Still no wifi...No what?
    02-08-2018 07:03 PM
  9. B. Diddy's Avatar
    Probably better to create a new thread for that question.
    02-08-2018 07:48 PM

Similar Threads

  1. where do i find my ssid on my galaxy s8+
    By becka j in forum Samsung Galaxy S8 & S8+
    Replies: 1
    Last Post: 02-06-2018, 01:53 AM
  2. Samsung Galaxy Tab Pro 8.4 SM-T320 won't boot up
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-06-2018, 01:40 AM
  3. About my Samsung galaxy tab A
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-06-2018, 12:25 AM
  4. Replies: 0
    Last Post: 02-05-2018, 07:47 PM
  5. Replies: 1
    Last Post: 02-05-2018, 12:51 PM
LINK TO POST COPIED TO CLIPBOARD