1. Android Central Question's Avatar
    I have a galaxy S7. I was looking to reinstall a gaming app I used to play when trying to do so I see a message on the Google play store under the app that says "your device isn't compatible with this version". I havnt changed anything with my phone. I live in the USA and that's the location in my Google play settings. Apps that won't download include: Kohls, Pinterest, Trails Frontier and probably more. These are well know apps and I can't figure out what's the problem. I've tried deleting Google play, cach as well. But no luck. Please help.
    02-06-2018 06:19 AM
  2. methodman89's Avatar
    Go to Settings, About Device, verify your running version and check for updates. Clear your cache and reboot.
    Do you still have the same issues?
    02-06-2018 08:04 AM
  3. Dustin Greenway's Avatar
    Andriode version is 7.0. Cleared cash and reboot and still no luck.
    02-06-2018 08:51 AM
  4. Mooncatt's Avatar
    How are you navigating to these apps? Generally when you search for something on Play, it'll only show results for apps that are compatible with your device. If not, then it's excluded from the results and you only notice it if you navigate to it via a direct link.

    So I'm wondering if maybe you're going to a different version of those apps meant for different device types, like older/lower spec phones for example.
    02-06-2018 09:05 AM
  5. Dustin Greenway's Avatar
    You're correct. When I try to search for the app on Google Play it won't show up. Therefore I have to go through the apps website find the link to Google Play and then click on it it. That's when I see the message. But these are popular apps. Apps mainly in America. But for some reason I can't download them.
    02-06-2018 09:16 AM

Similar Threads

  1. [App] [4.0+] Battery Saver 5X
    By sylsau in forum Android Apps
    Replies: 1
    Last Post: 02-13-2018, 12:04 AM
  2. Why is my phone not downloading anything
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 02-07-2018, 06:40 AM
  3. Google Play not working after recent updates.
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-06-2018, 10:35 AM
  4. Google suspending app that I have never released
    By appninza in forum Android Apps
    Replies: 2
    Last Post: 02-06-2018, 06:14 AM
  5. Downloading Problem
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-06-2018, 05:22 AM
LINK TO POST COPIED TO CLIPBOARD