1. Android Central Question's Avatar
    Hi All.

    I have the following situation on my Huawei CAM L03 Y6 II.

    WiFi gets very slow when turning on Bluetooth (ie. Page loading in browser takes for ever) .

    A soon as I turn Bluetooth off, browsing starts working fine again (pages load fast).

    This happens on my Huawei CAM L03 Y6 II Android 6.0.

    Any ideas, suggestions?

    Thanks!

    Juan
    03-03-2018 09:45 AM
  2. Rukbat's Avatar
    I'm guessing that you're not that close to the router, and you have a weak 2,.4GHz wifi signal. Since Bluetooth is also on 2.4GHz, it's interfering with your wifi signal. (If you're close to the router, the wifi antenna in the phone may have gotten disconnected, or the wifi receiver may have gone bad.) There's not much you can do (unless there's a problem with the phone and you get it fixed) except to use 5GHz wifi if you can, or to turn Bluetooth off when you're using wifi if you can't. You can't change where they operate.
    03-03-2018 06:32 PM

Similar Threads

  1. Replies: 6
    Last Post: 10-07-2018, 03:18 PM
  2. Coming back to Android to a Huawei mate 10 pro after year with IPhone 7 plus
    By shoaib shah in forum Huawei Mate 10 & Mate 10 Pro
    Replies: 12
    Last Post: 03-12-2018, 06:06 PM
  3. Why has sound stopped working when casting movies
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-03-2018, 10:21 PM
  4. Replies: 1
    Last Post: 03-03-2018, 05:28 PM
  5. Replies: 2
    Last Post: 03-03-2018, 05:16 PM
LINK TO POST COPIED TO CLIPBOARD