1. HelenMV's Avatar
    Hi. I have a specific problem and I hope someone can help me. I have an android phone, no brand, it says Android 5.1 if that helps.
    My phone stopped being able to download photos from apps recently. It can sometimes download apps, sometimes not, but photos from e.g. Facebook or Imgur, it says 'something went wrong' or 'download failed'. However, the moment I unmount my SD card, it works normally.
    So I assumed it's some file corrupting it, I plugged it into a pc and deleted all files not needed, of the SD and phone storage. Suddenly it worked. It's been 5 days, it's mysteriously not working again, except this time it won't let me copy anything to the SD card while plugged into a pc as external storage, and there are no rogue files to delete.
    How come it worked for 5 days and now doesn't work again? It seems the SD card is the problem, since everything's okay as soon as I unmount it. What the hell?
    03-20-2018 04:27 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! The SD card could be corrupt, defective, or counterfeit. Install SD Insight to see if the card is genuine or counterfeit. Counterfeit cards are programmed to report more storage than they actually have, and if you try saving more than the card can actually hold, then files can start getting corrupt. (Be aware that SD Insight might not work on all Nougat devices.)


    If it's a valid card, then go to Settings>Storage, Unmount the card, remove it, and insert it into your computer. Can the computer read these files? Backup as much as you can right now, then run chkdsk to look for bad sectors: http://forums.androidcentral.com/amb...d-sd-card.html.
    03-25-2018 10:34 PM

Similar Threads

  1. Replies: 2
    Last Post: 03-21-2018, 03:11 PM
  2. Galaxy S9= keep getting message "WiFI Disconnected" while at home
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-20-2018, 06:06 PM
  3. Voicemail icon that is not Visual Voicemail
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-18-2018, 11:46 AM
  4. Can't convert .Avi to play on Moto e4
    By esjayy in forum Moto E
    Replies: 1
    Last Post: 03-16-2018, 04:07 PM
  5. Replies: 1
    Last Post: 03-15-2018, 03:02 PM
LINK TO POST COPIED TO CLIPBOARD