1. Android Central Question's Avatar
    This problem drives me crazy.
    I have a LG G pro 2 with android 5.0.1
    .
    Wifi is on/off continuously and/or connected to %1$s.
    When connected it keeps searching for a new connection, without in my believe any necessity.

    Tried everything. After a reboot it seems to work 5 minutes, then it starts all over.

    Location and other settings, like wifi stays off , location etc seems according as suggested (out or off)

    The location services from google-playstore disconnecting will help some time, but it starts itself.
    Without playstore you can not use the phone.

    Some suggestions?
    03-26-2018 04:12 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does this also happen in Safe Mode? How to turn on safe mode on Lg G Pro 2
    03-26-2018 11:24 AM
  3. RumoredNow's Avatar
    We had that with a different phone just about a week ago.

    https://forums.androidcentral.com/sh...=1#post6196301

    Weird.
    B. Diddy likes this.
    03-26-2018 12:27 PM
  4. RumoredNow's Avatar
    Looks like it might be a bit of PHP programming? https://wordpress.stackexchange.com/...ng-of-s-1s-etc


    Not sure why it comes up in relation to device connection.

    OP here has an LG G pro 2. OP in the other thread had a Galaxy S4. Looks like they share one common factor at least. Android 5.0.1.


    Hope this helps pull someone in who knows about PHP.
    B. Diddy likes this.
    03-26-2018 12:46 PM
  5. B. Diddy's Avatar
    We had that with a different phone just about a week ago.

    https://forums.androidcentral.com/sh...=1#post6196301

    Weird.
    Thanks, I thought that sounded familiar!
    RumoredNow likes this.
    03-26-2018 01:25 PM
  6. Rukbat's Avatar
    When you open the Wifi page, it starts searching, regardless of any other settings. It's assumed that you're there to choose a Wifi connection, so it has to search for them. Even if searching is disabled, manually going to that page causes searching.

    As for the %1$s, that's possible in string functions in other languages too (tortured, but possible - $ is the string variable indicator in PHP [and some dialects of BASIC]). It could be a programming error in LG's modification of Android. Instead of "not connected" it may be falling through to the same message whether it's connected or not, and if it's not connected, the source code is being output because $1 is null. (Some programmers should be handed a bullet and told to shoot themselves. They're not worth squeezing the trigger for.)
    RumoredNow likes this.
    03-26-2018 02:04 PM
  7. RumoredNow's Avatar
    It could be a programming error in LG's modification of Android.
    Note that it was also seen on a Galaxy S4 last week. They both (S4 and G Pro 2) topped out at 5.0.1.

    Maybe an App is causing this?


    Seems odd that it creeps in twice in a week on systems that haven't been updated in awhile...
    03-26-2018 06:48 PM
  8. source_transformer's Avatar
    I just updated the other thread:
    https://forums.androidcentral.com/as...ml#post6217356

    This notification is actually the Garmin Connect app.

    Frankly disappointed they haven't notified their users about this bug.
    B. Diddy and belodion like this.
    04-08-2018 06:07 PM
  9. Mrt2's Avatar
    Thank you for the help.
    Did come along with Wfif fixer and deleting google play. (Strongly suspected GMSservice and google location/ management service)


    Today a check of this request of mine.
    Tried save mode, and yes it was swapping continuing. deleted active googlep ay services, which didn't help really.
    Checked to end save mode and now for 2 hours a stable connection ??????

    Note I am rooted with Kingroot, I also suspect. Seems with Wifi fixer this is ( or is it wifi fixer ?) making a connection to baidu.com (Target Host is set to 百度一下,你就知道)
    Neither is this in my opinion not good prograam (shuold be http:\www etc - according other media) nor it is desireable!

    While typing this and starting wifi fixer, it al is starting over again and again
    ..........
    06-18-2018 06:34 AM
  10. source_transformer's Avatar
    see my previous reply - uninstall the garmin connect app - it is the cause of this cryptic looking error dialog:
    Wifi on/off continuously and/or connected to %1$s

    Alternatively if you want to keep the app - turn off the "Find my Phone" features.
    06-24-2018 07:08 PM
  11. Mrt2's Avatar
    Thank you source_tranformer,
    I don't have garmin connect app on my lg g pro 2.

    An update:In save mode it starts first with switching wifi on off, then it seems pretty stable.
    Putting it out of save mode the first minuts/time wifi seems stable .
    ZAfter that without wifi fixer it is not workable.
    06-27-2018 03:50 PM

Similar Threads

  1. update software , Registering device and then got processing failed
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 07-28-2018, 06:50 AM
  2. Replies: 6
    Last Post: 04-15-2018, 11:13 PM
  3. Replies: 1
    Last Post: 03-26-2018, 12:29 PM
  4. SMS Messages via Facebook Messenger -- How to attach photos?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 03-26-2018, 03:04 AM
LINK TO POST COPIED TO CLIPBOARD