1. Android Central Question's Avatar
    My phone is an Honor.

    I'm not able to use the app. I've tried deleting and reinstalling Uber, I've clear cache and data for Google Services, Uber and Google Play Store. Nothing works.
    05-09-2018 08:48 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Which Honor phone?
    05-10-2018 11:01 AM
  3. aku_02's Avatar
    Same here, using an honor view 10 and jugnoo, uber won't work. keeps showing the error 'google services are updating'. tried switch off, cleared cache, cleared data, updated the apps. Nothing helps. I badly need to use this apps, to come home from office. Please, if someone could help!! But Olacabs works just fine. Maps open like it usually does.
    05-10-2018 11:04 PM
  4. B. Diddy's Avatar
    Welcome to Android Central! See if you can wipe the cache partition (which is different from the app cache). Use the hardware key method to get to the Recovery menu, and select Wipe Cache Partition (instead of Wipe Data): https://hardresetmyphone.com/hard-re...honor-view-10/
    05-11-2018 03:58 AM
  5. Mike Ktx's Avatar
    so i have a Huawei p10 plus with the same issue. I've done everything above and wiped the cache partition and still no help

    Mike
    05-11-2018 09:15 AM
  6. Mike Ktx's Avatar
    found the answer for me. try this one: https://productforums.google.com/for...ay/proQdv6kR9M
    B. Diddy likes this.
    05-11-2018 09:31 AM
  7. Zia Jadoon's Avatar
    I suffered the same problem, it can easily be solved by clearing app cache of Google play services and also the data. Only clearing cache doesn't works.
    05-12-2018 09:18 AM
  8. Colin Dunn's Avatar
    Also had the same problem occurring recently on a Huawei P10 Lite. To resolve you have to clear the "Google play services data".

    Settings >apps>Google play services> storage> manage space >. Clear all data.

    It is also worth clearing all the caches aswell, but removing the data as instructed above seems to solve it
    05-12-2018 09:27 PM
  9. pc58t's Avatar
    this works for me, thank you !
    05-14-2018 02:48 AM
  10. Bankai113's Avatar
    Hello. I have an Honor 6x and I am saying the exact same problem on my uber. Please help. what should i do ?
    05-14-2018 03:07 AM
  11. A Jaidka's Avatar
    See this video
    05-15-2018 02:44 PM

Similar Threads

  1. Couldn't open connection to server please help
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 12-16-2018, 09:40 PM
  2. Update for huawei mate 10 pro anyone?
    By critta71 in forum Huawei Mate 10 & Mate 10 Pro
    Replies: 21
    Last Post: 06-16-2018, 02:57 PM
  3. Is anyone else having trouble with getting into private mode?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-11-2018, 06:24 AM
  4. Why can't I open attachment on messenger
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-10-2018, 11:09 AM
  5. Replies: 1
    Last Post: 05-10-2018, 11:05 AM
LINK TO POST COPIED TO CLIPBOARD