1. Android Central Question's Avatar
    I've tried adding multiple accounts to select the one I'd like to use but it still displays the "This application is not currently supported for your account" message.
    05-11-2018 11:28 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Which device, and is there anything special about the account? Is it a Family Link account?
    05-11-2018 09:32 PM
  3. Mjhammy's Avatar
    It's a Samsung Galaxy J5 and from what I'm aware, there isn't anything I'd call special about it
    05-12-2018 07:02 AM
  4. B. Diddy's Avatar
    I know you just did a factory reset, but try going to Settings>Apps, select Google Opinion Rewards, and Clear Cache/Clear Data.
    05-12-2018 10:20 AM
  5. Mjhammy's Avatar
    I have but when I do it gives the message mentioned above, but when I don't clear them it just takes me to the creation screen upon opening it
    05-12-2018 03:37 PM
  6. Rukbat's Avatar
    Why do you have multiple Google accounts in the phone? You can have multiple email accounts with only 1 Google account. The multiple accounts is probably what's causing the problem.
    05-12-2018 04:43 PM
  7. Mjhammy's Avatar
    I only had one but, after some searching, the closest to a solution required having multiple on the device, clear the data and then reload it selecting the account you want to use, but it still gave the same message. After that, I deleted the other account since there was no need for it to still be there. The problem only occurred after the factory reset.
    05-12-2018 05:08 PM
  8. B. Diddy's Avatar
    I'm always a little wary of trying this, but you could see if clearing the cache for Google Play Services helps. If not, then also clear the data.
    05-15-2018 12:05 AM
  9. Mjhammy's Avatar
    I'll try it again but I honestly don't think it will work.

    Nope, no luck.
    05-15-2018 11:05 AM
  10. B. Diddy's Avatar
    I looked at the Opinion Rewards help page, and it mentioned that the user has to be over 18 to be eligible -- is that the case for you? (I realize it was working before the reset, but I bring this up in case you somehow added a birthdate to your account some time in between.)

    Obviously, I'm starting to grasp at straws. Hope someone else can offer some help!
    05-15-2018 11:05 PM
  11. Mjhammy's Avatar
    That might be why but I've just updated the age of it. I've removed all cache and data however, it is still displaying the same message.
    Thank you for helping me this entire time, If it comes to it, I'll just make another account once it gets to the 20th because my £7.98 is due for a deduction on the 25th and I'd rather not waste it.
    B. Diddy likes this.
    05-16-2018 02:31 PM
  12. Mjhammy's Avatar
    Thank you for all your help, I'm now signed back into the account and I'm not sure if it's from updating my profile or because it updated (Probably the latter) and I still have my £7.98 thankfully.
    But I still have another problem if it's not too much to ask, the reason I did a factory reset; I don't know what happened, but my phone was and still is unable to stream videos through the internet and any content that is live, it shows the 1st frame but audio still plays and upon pause/unpausing it only shows that frame. I was hoping you might have some insight on what could be causing this.
    B. Diddy likes this.
    05-17-2018 01:33 PM
  13. B. Diddy's Avatar
    Glad Opinion Rewards seems to be working again!

    Is the streaming issue only on the browser? If so, which browser are you using, and have you tried a different browser? If the phone is on Marshmallow or below, make sure Android System Webview is updated in the Play Store. If it's on Nougat or above, make sure Chrome is updated (since Android System Webview is folded into Chrome in Nougat).
    05-17-2018 07:43 PM
  14. Mjhammy's Avatar
    The issue is only in 'Internet' and the Webview is up to date.
    I've reinstalled chrome and it worked. I checked Internet again and it started working. I've just re-uninstalled Chrome and it still works.
    Thanks for all your help!
    B. Diddy likes this.
    05-18-2018 10:34 AM

Similar Threads

  1. Huawei P20 Pro no badge dot on missed calls and new messages
    By Android Central Question in forum Huawei P20 & P20 Pro
    Replies: 13
    Last Post: 01-17-2019, 02:17 PM
  2. Disable Google Apps in MIUI 9 and MIUI 9.5
    By gnjha in forum Xiaomi Android Phones
    Replies: 1
    Last Post: 08-16-2018, 10:09 AM
  3. Why are photos so grainy in auto?
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 05-12-2018, 04:53 PM
  4. I can't reply or send mails
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-11-2018, 11:05 AM
  5. Replies: 3
    Last Post: 05-11-2018, 10:57 AM
LINK TO POST COPIED TO CLIPBOARD