1. Android Central Question's Avatar
    Error loading media in facebook messenger since my phone updated yesterday. So frustrating! Any suggestions what to do to fix it. I wish they would have left it alone!
    06-26-2018 01:20 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Which phone? Are you talking about a system update or an update to Facebook Messenger?
    06-26-2018 12:53 PM
  3. Romdog64's Avatar
    I'm having the same problem with my Galaxy s7 active. Cannot send pictures through facebook messenger and I've tried resetting network connections, and uninstalled/re-installed both Facebook and messenger, and shutting my phone off waiting 10 minutes then turning it back on
    06-26-2018 04:16 PM
  4. B. Diddy's Avatar
    Did this start happening after the Oreo update? That update seems to be pretty problematic. Try wiping the system cache partition, which can sometimes help with general issues after a major system update: https://support.t-mobile.com/docs/DOC-30240
    06-26-2018 06:34 PM
  5. Rycuda's Avatar
    Im having the same problem since the update. Ive cleared the memory on messenger app, reset my phone, reset the network settings to default, and made sure the permission to access media is still on yet nothing is working. Please fix this then never update our galaxy s7 actives again cause all it does is slow down the phone and mess everything up. Thank you
    06-26-2018 06:35 PM
  6. B. Diddy's Avatar
    That sounds frustrating. I'd send feedback to Samsung about this, since they're the ones responsible for the update.
    06-26-2018 08:48 PM
  7. Melissa Anne76's Avatar
    I've also been having this problem since the update. Can't send photos or video through FB messenger. When I try, I get "Error loading media" Extremely frustrating, but glad to see it's not just my phone. Hopefully this is fixed for all of us soon!
    06-28-2018 07:51 PM
  8. ECD7911's Avatar
    I found this solution on a post to fix Google Photos. It worked like a charm across all apps, Messenger included.

    FIXED!!!

    Was able to track down a fix from another help thread and this worked for my S7 Active, not sure if it will work outside of Samsung devices, but follow these steps:

    1. Settings (widget symbol in upper right)
    2. Apps (Default apps, App permissions)
    3. Tap on the three-dot symbol on upper right of APPS menu
    4. Select Show system apps
    5. Scroll down. Select Media Storage
    6. Long press on Storage
    7. Press both Clear Data and Clear Cache
    Clear Data will give you a big warning that application data will be permanently deleted. This is not deleting your photos and videos. It is only deleting how the apps find them. Once this is deleted the apps will start finding them again which is what resolves the problem.
    8. Wait for apps to find all the photos and videos. You can use your phone during this time but it may take awhile until you see all your pictures. You can restart your phone now, and everything will be loaded back to normal.

    Huzzah!
    07-06-2018 10:38 AM
  9. CooknWithNapalm's Avatar
    ECD7911 now all my photos and videos are gone. Thanks for the support. You too B Diddy for liking his response. You better have a fix for that. I have a S7 Active with Android Oreo
    07-07-2018 11:39 PM
  10. Golfdriver97's Avatar
    ECD7911 now all my photos and videos are gone. Thanks for the support. You too B Diddy for liking his response. You better have a fix for that. I have a S7 Active with Android Oreo
    Welcome to the forums. Did you have Photos back up and sync enabled in Settings? If not, there may not be much that can be done to retrieve the lost photos.
    07-08-2018 11:15 AM
  11. sydneycooper1979's Avatar
    Mod Note: Please keep discussion civil and on topic. Please remember that the people in here are only trying to help and are just regular people that love tech. Thank you!
    belodion and Golfdriver97 like this.
    07-08-2018 01:40 PM
  12. B. Diddy's Avatar
    ECD7911 now all my photos and videos are gone. Thanks for the support. You too B Diddy for liking his response. You better have a fix for that. I have a S7 Active with Android Oreo
    Welcome to Android Central! Can you give us more details about what led you to try ECD7911's solution? If you had a different problem, it might not have called for this solution. Also, use your file manager app to look directly in the /DCIM/Camera directory -- are the photo and video files still there (assuming you took them with your Camera app)?

    For what it's worth, I've seen quite a few people respond positively to this solution around the forums, which is why I liked the post.
    07-09-2018 11:23 AM
  13. JohnnyBra's Avatar
    ECD7911, thanks so much! Wife & I Had the exact same problem on our Galaxy S7 Actives since the Oreo update. Cleared media storage service data, rebooted my phone, took a photo, and left it sit for a few mins. Gallery reloaded all the files on the SD card and attachment loading to Facebook Messenger works again!
    07-09-2018 11:32 AM
  14. JohnnyBra's Avatar
    CooknWithNapalm: Deleting the cache from the "Media Storage" service doesn't delete the files from your device. They're still physically there on the media card. If you use any file browser app, you can still see them there in your DCIM folder and Camera Folder. The Samsung Gallery simply doesn't see them any more. It will eventually, it just takes time.

    For me, after clearing the cache, I rebooted the phone, opened the camera, and took a single photo. It was the only thing showing in my gallery at first. Let the phone go to sleep and 5 mins later checked again. It had found all the media that was still present on the SD Card. And attachments in Messenger work again.
    B. Diddy likes this.
    07-09-2018 11:35 AM
  15. Margaret V's Avatar
    OK, so I'm a little late on the uptake for this problem...I've been sending the photos, but in a rather roundabout way, from within the gallery.
    Saw this just tonight, and tried the suggested solution. Took just one pic after restarting my phone, and....waited.
    I'm not very good at waiting! It was less than 5 min, all photos are back.
    THANK YOU ECD7911!!
    07-21-2018 10:49 PM
  16. Denton Smith's Avatar
    Like a charm thank you. I was skeptical at first but it worked out
    07-22-2018 03:53 PM
  17. creativespirit8's Avatar
    I've tried the recommendations here and from the YouTube video I watched, but I'm still getting the error loading media message. Does it make a difference if I note that the storage is internal or SD?
    07-24-2018 08:11 PM
  18. lauroriosje's Avatar
    Super good help. Works great. Many thanks.
    08-05-2018 04:45 PM
  19. lauroriosje's Avatar
    Super good help. Works great. Many thanks.
    08-05-2018 04:57 PM
  20. RN_mama's Avatar
    Tried this on my husband's S7 active. Gave us heart attack for about 10 mins then we restarted the phone and waited for about 5 mins and it works perfectly now.
    08-25-2018 11:35 PM

Similar Threads

  1. Why do my apps reload when i swap between apps?
    By Insane225 in forum General Help and How To
    Replies: 3
    Last Post: 06-27-2018, 03:41 PM
  2. Why is the Times on my messenger incorrect
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-26-2018, 12:56 PM
  3. A radio sounds keeps coming on my phone how do i stop it from coming back on
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 06-26-2018, 11:31 AM
  4. Replies: 1
    Last Post: 06-26-2018, 05:35 AM
  5. Honor 8 (FRD-L14) apk updates
    By Android Central Question in forum Honor 8
    Replies: 0
    Last Post: 06-26-2018, 01:08 AM
LINK TO POST COPIED TO CLIPBOARD