1. Android Central Question's Avatar
    Can't seem to update to firmware version N950FXXS4CRG1 (July Security Update)
    I've already tried both "wipe cache partition" and factory resetting my phone, then downloading the update, but still I get the "Unable to install update. The download file is invalid" error.
    07-24-2018 08:35 AM
  2. Rukbat's Avatar
    Do you have enough free internal storage for the update file? (It could be over 1GB, depending on what's in it.)

    Or, if you've made any changes to the system (like rooting or flashing a custom ROM), you're just getting the wrong error message - it should be something like "Unable to install update." with no reason given.
    07-24-2018 06:07 PM
  3. Milkha Villena's Avatar
    I have the same problem. There's a 2mb error.
    07-25-2018 12:08 AM
  4. Hrv Ga's Avatar
    mine gives a 3mb or 4mb error.. I have tried to download the update several times.. And the same message appears.. That the downloaded file is invalid..
    07-29-2018 06:36 AM

Similar Threads

  1. [SOLVED] Samsung S6 can't connect to public WiFi
    By mtbbuxton in forum Ask a Question
    Replies: 17
    Last Post: 08-14-2018, 04:02 PM
  2. Replies: 6
    Last Post: 08-11-2018, 08:05 PM
  3. Replies: 1
    Last Post: 07-24-2018, 10:08 AM
  4. [Install problem]
    By helen o brien in forum Ask a Question
    Replies: 1
    Last Post: 07-24-2018, 06:52 AM
  5. Why is my husbands smart phone getting all of MY pictures from my Android LG?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-24-2018, 06:39 AM
LINK TO POST COPIED TO CLIPBOARD