1. Android Central Question's Avatar
    I was just scrolling down the instagram when my phone ZTE BLADE A310 just stopped working. Display brightness goes down to about 50% and no button works. When i connect to PC it don't show up. I can just see driver of the device in device manager. Tried to Fast Boot, but it says "Device not found". I cant disassemble the battery on phone and don't have alternate button for shutting down. Can someone help me?
    07-27-2018 01:36 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! You said the brightness dropped by 50%, but is anything still showing on the display, or is it blank?

    Try forcing a shutdown by pressing and holding Power for about 20 seconds. Then wait a few seconds, and try powering back on again.
    07-27-2018 05:51 PM

Similar Threads

  1. Galaxy S9 and S9+ owners, were there any other phones you were considering?
    By TextMeMaybe in forum Samsung Galaxy S9 & S9+
    Replies: 36
    Last Post: 08-04-2018, 10:49 AM
  2. I love My S9 Plus, but regret the color
    By Projectphill in forum Samsung Galaxy S9 & S9+
    Replies: 7
    Last Post: 07-27-2018, 10:46 PM
  3. Replies: 1
    Last Post: 07-27-2018, 05:56 PM
  4. How do I change my name on cell phone that callers see displayed
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-27-2018, 03:03 PM
  5. How to download pictures from cloud back to phone?
    By Aztek Warrior in forum Google Pixel 2 & Pixel 2 XL
    Replies: 3
    Last Post: 07-27-2018, 01:49 PM
LINK TO POST COPIED TO CLIPBOARD