1. Android Central Question's Avatar
    My phone had decent signal and then I sent it in to Samsung to be repaired, the screen had become discolored. I got it back and suddenly it won't stay connected to Verizon's network. Right now it says LTE with one bar but when I pick it up the bar disappears. It loads pages very slowly, or gives me a connection error and says I'm offline. Has anyone had this problem? I've factory reset my phone, I've removed and reinserted the Sim card, I've switched the device off my account and then added it back. I spent an hour doing troubleshooting with Verizon and they say the issue must be the phone.
    09-04-2018 07:17 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! I'd guess they disrupted the antenna somehow during the repair. Contact Samsung (or whoever repaired it) and discuss the problem with them.
    Kodak2 likes this.
    09-05-2018 11:49 AM

Similar Threads

  1. Why does my camera has these black marks and is blurry?
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 09-05-2018, 03:50 AM
  2. Why apps takes so long to load
    By Android Central Question in forum Ask a Question
    Replies: 4
    Last Post: 09-04-2018, 10:54 PM
  3. Android battery monitor not responding
    By Zul Hairi Mohd Yusof in forum General Help and How To
    Replies: 1
    Last Post: 09-04-2018, 07:24 PM
  4. Replies: 1
    Last Post: 09-04-2018, 06:49 PM
  5. How to change my contacts profile picture on Wechat?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 09-04-2018, 04:50 PM
LINK TO POST COPIED TO CLIPBOARD