1. Android Central Question's Avatar
    Hello all, I am trying to use my Samsung tab sm-t580 after many months of not using it due to not being in school. The last time I used the tablet it worked perfectly. It was in a storage room for 8 months or so. I tried charging it, but it just stays at 0%. When I try to boot it, all it does is get to the start screen and give me a warning that I'm slow charging and then shuts down(despite using a fast charger from my note 9). Please help me figure out what is going on as I've never dropped or mishandled this tablet, and I am worried not using it may have permanently damaged the battery.
    10-25-2018 10:35 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Keep it plugged into a wall outlet and let it charge for at least 6 hours undisturbed. Then try powering on again.
    10-25-2018 10:49 AM
  3. Rukbat's Avatar
    In the future, when storing it away, use or charge it until the battery is at about 50% (lowest self-discharge point). then check the charge every 2 months or so. Lithium batteries can't be safely stored with a load on them for 8 months. (And the fact that it's connected to the tablet is a small load.)
    B. Diddy likes this.
    10-25-2018 12:21 PM

Similar Threads

  1. clickable addresses in SMS
    By DerHof in forum Ask a Question
    Replies: 13
    Last Post: 10-25-2018, 06:11 PM
  2. 'Number not recognised' in dialer
    By NightOrchid in forum Nokia 7 Plus
    Replies: 2
    Last Post: 10-25-2018, 02:19 PM
  3. Phone rings the flash on the back is flashing. It's not set.
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-25-2018, 10:48 AM
  4. Why my samsung note 4 has become laggy with softwere bugs?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-25-2018, 10:34 AM
  5. Whatsapp sound not playing default tone
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-25-2018, 09:12 AM
LINK TO POST COPIED TO CLIPBOARD