1. Android Central Question's Avatar
    I have just purchased a new phone. When I go to the playstore to download Instagram it says
    "Your device isn't compatible with this version"

    How can I fix this?
    12-06-2018 02:53 AM
  2. belodion's Avatar
    Have you checked that your phone meets the software and hardware requirements, as described by the developer?
    12-06-2018 06:10 AM
  3. B. Diddy's Avatar
    Welcome to Android Central! It might also be a regional restriction. What part of the world was your phone intended for, and do you live there?
    12-06-2018 02:54 PM

Similar Threads

  1. all of my apps iv bought are showing that i need to repurchase.. Help!
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-09-2018, 09:01 PM
  2. Moto G6 Delay on Settings App
    By Trevin K in forum Android 8.0 Oreo
    Replies: 32
    Last Post: 12-09-2018, 02:03 PM
  3. Hello I am using mi 4 phone
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-06-2018, 02:08 AM
  4. Can i install Xposed and Magisk modules via TWRP without having Xposed or Magisk?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-06-2018, 02:07 AM
  5. Can i read my girlfriends messages in messenger from my phone?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-06-2018, 01:56 AM
LINK TO POST COPIED TO CLIPBOARD