1. Android Central Question's Avatar
    Hi there, since a few days ago I can´t download certain apps from the play store while being connected to my home Wifi (I can download them using 4G but I don´t have a big data plan).
    For example I can download Twitter app but Facebook gets stuck in downloading forever.

    Also tried:
    Clearing cache and data of every related app (google play store, play services, downloading manager).
    Factory reset
    Restarting router
    Changing date and time of the phone, router, etc

    Thank in advance!
    12-07-2018 11:00 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Strange. Try going into the router's settings (via your computer browser) and see what happens if you disable IPv6.
    12-07-2018 11:18 PM
  3. repiru's Avatar
    Hi I'm the one who asked this question. I believe my IPv6 is already disabled / not enabled on my router.
    12-07-2018 11:29 PM
  4. B. Diddy's Avatar
    Can you check? Also, what about other wi-fi networks (like at your local library or coffeeshop)?
    12-07-2018 11:42 PM
  5. repiru's Avatar
    Yeah, IPv6 is disabled. I havent checked other wifi's but I tried with my 4G data and it works..
    12-08-2018 12:33 AM
  6. B. Diddy's Avatar
    It'd be helpful to test out other wi-fi networks, which could help narrow the problem down to your router.
    12-08-2018 01:55 AM
  7. repiru's Avatar
    Okay I just tested from my neighbor's wifi network and everything works fine. Guess the problem is on my router/isp. But I did a speedtest and it showed 50mbps which is perfectly fine, and my wifi works well on my phone other than on the playstore?
    12-08-2018 02:35 AM
  8. B. Diddy's Avatar
    Try changing your DNS server to Google's (8.8.8.8 or 8.8.4.4) or CloudFlare (1.1.1.1). http://www.howtogeek.com/167533/the-...ur-dns-server/
    12-08-2018 03:23 AM
  9. repiru's Avatar
    Changing the dns server did no good either..
    12-08-2018 10:46 AM
  10. B. Diddy's Avatar
    Hmm. How about temporarily disabling any security on the router? Also, check the router manufacturer's website to see if there's a firmware update available.
    12-08-2018 11:33 PM

Similar Threads

  1. Just purchased an old asus tablet that can't find any updates
    By Android Central Question in forum Ask a Question
    Replies: 9
    Last Post: 12-08-2018, 09:17 PM
  2. Smart Boost on OnePlus 6T
    By ironass in forum OnePlus 6 & 6T
    Replies: 7
    Last Post: 12-08-2018, 03:07 PM
  3. December update - vibration not working
    By Dan L2 in forum Google Pixel & Pixel XL
    Replies: 2
    Last Post: 12-08-2018, 06:25 AM
  4. I can only hear audio on right side earbuds
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-07-2018, 11:22 PM
  5. How do I turn off enhanced LTE on my Alcatel Android phone?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-07-2018, 10:42 PM
LINK TO POST COPIED TO CLIPBOARD