1. Android Central Question's Avatar
    Hello, I have just recently built a new PC and am having some difficulty getting my S9+ to show as a storage device on my pc. I have tried everything that you can find on google from wiping the cache partition, updating/reinstalling drivers, restarting everything, using a different USB cable and port, etc. I have two S9+s, both do not work on this computer however my sister's Note 5 works fine, but when I plug my phones into her computer they work fine as well... so it seems to be just an S9 issue maybe with a windows update? Has anyone else had this issue ? Help most appreciated!

    thanks.
    12-28-2018 04:13 PM
  2. Golfdriver97's Avatar
    Welcome to the forums. When you plug the phone in, you should get a notification for charging. Change that to another option, I think it's something like file transfer, and your PC should be able to read the phone.
    12-28-2018 04:26 PM
  3. spookzillas's Avatar
    Okay, I had to log in to reply forgot to do that. Anyway @Golfdriver97 , I had tried that as well. USB Debugging is turned on as well and set to MTP. I've tried changing it to the other settings as well thinking maybe it's just a weird glitch but no luck. Also, sometimes the phone WILL appear as a device, but it loads incredibly slow and sometimes makes the entire explorer crash and i have to restart it. I have USBDeview running to show that it appears as a Samsung device and it IS there, just not reading as a storage device basically.
    12-28-2018 04:35 PM
  4. Golfdriver97's Avatar
    Maybe Samsung drivers need to be installed? Been a long time since I plugged a Samsung into my PC.
    12-28-2018 04:50 PM
  5. spookzillas's Avatar
    All drivers are installed and up to date. I have tried rolling them back to older versions as well. Plugging it in completely slows or crashes explorer.
    12-28-2018 05:41 PM
  6. Golfdriver97's Avatar
    Tried a different cable and USB ports?
    12-29-2018 10:00 AM
  7. Rukbat's Avatar
    USB 3.0 ports in the computer and USB 3.0 cables? Change to a USB 2.0 cable (you can still use a 2.0 cable with a Type C connector) Or a USB 3.1 cable. (The Pixel 2 has that problem - to the point that updating using that arrangement corrupted the phone.)
    12-29-2018 02:16 PM

Similar Threads

  1. Why do my jpg photos download as a png on my S9?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-29-2018, 09:42 AM
  2. Replies: 1
    Last Post: 12-28-2018, 03:35 PM
  3. Why is my Galaxy Watch not display txt notifications anymore?
    By Android Central Question in forum Samsung Galaxy Watch
    Replies: 0
    Last Post: 12-28-2018, 03:24 PM
  4. S Health not syncing map
    By uai1 in forum Samsung Gear Sport
    Replies: 0
    Last Post: 12-28-2018, 02:49 PM
LINK TO POST COPIED TO CLIPBOARD