1. Android Central Question's Avatar
    All right, i screwed up pretty bad trying to fix the tablet of a friend (Samsung galaxy tab 2 10.1) that was going to just dump it since it hasnt work in two year. Pluged it in, charged and turned it on, the color were in reverse. Fine i opened the back and tried to unplug, clean and reconnect the ribon for the screen. Decided since i was there to look if everything was well secured in place so I unpluger everything. Now heres the screw up, when removing the middle ribon (the screen sensor one) i totaly broke the socket... Hard to explain but the gold and black "cover" underneath the latch is broke.. My question here is do i have to replace the whole motherboard for the socked or is it available somewhere ?
    Im a total noob at this, I feel stupid for breaking something that was fine prior to trying to fix the damn screen color..
    Anyway any help would be appreciated.
    01-02-2019 09:30 PM
  2. spantch101's Avatar
    All right, i screwed up pretty bad trying to fix the tablet of a friend (Samsung galaxy tab 2 10.1) that was going to just dump it since it hasnt work in two year. Pluged it in, charged and turned it on, the color were in reverse. Fine i opened the back and tried to unplug, clean and reconnect the ribon for the screen. Decided since i was there to look if everything was well secured in place so I unpluger everything. Now heres the screw up, when removing the middle ribon (the screen sensor one) i totaly broke the socket... Hard to explain but the gold and black "cover" underneath the latch is broke.. My question here is do i have to replace the whole motherboard for the socked or is it available somewhere ?
    Im a total noob at this, I feel stupid for breaking something that was fine prior to trying to fix the damn screen color..
    Anyway any help would be appreciated.
    Can you post a pic of the damage?
    01-02-2019 09:33 PM
  3. aless888's Avatar
    01-02-2019 09:53 PM
  4. spantch101's Avatar
    Hmm are any of the pins broken ? or is it just the fastener broken ?
    01-02-2019 10:08 PM
  5. aless888's Avatar
    yep some of the gold pins are definitly broken...
    01-02-2019 10:10 PM
  6. aless888's Avatar
    here for a closer view.. Note that the touch screen was working fine before I venture in the back panel! https://ibb.co/HzRV8q2
    01-02-2019 10:27 PM
  7. spantch101's Avatar
    hard to see the pin damage in the photos. would have to see in person to assess actual port damage. looks like top clip is broken. assuming it is missing pins you will need to replace the module . and it looks to be directly fitted to the main PCB . this kind of module is usually soldered into place and very difficult to repair at home. unless you have a very fine tipped soldering tool with some of the more steady hands to perform the operation. some phone repair places have a skilled soldering artist. but it's not typically a job for the average Mr fix it. i struggled getting these types of modules fixed on a 16 pin setup that one looks like a real pain to fix.
    01-03-2019 05:46 PM

Similar Threads

  1. Missed calls not showing in call log in vivo v7+
    By mital boda in forum General Help and How To
    Replies: 1
    Last Post: 01-03-2019, 09:50 AM
  2. Replies: 1
    Last Post: 01-02-2019, 01:31 PM
  3. disable android dolphin web browser bottom tool bar in full screen mode
    By Android Central Question in forum Android Apps
    Replies: 1
    Last Post: 01-02-2019, 01:30 PM
  4. disable android dolphin web browser bottom tool bar in full screen mode
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-02-2019, 01:08 PM
  5. Replies: 0
    Last Post: 01-02-2019, 12:56 PM
LINK TO POST COPIED TO CLIPBOARD