1. Android Central Question's Avatar
    My AndroidOne MotoX4 recently updated to Android Pie, and with it Google gave me their new Files by Google app (Or Files Go as it was called a few months ago)

    This is fine and all, but I relied heavily on the old Files app to be able to access certain system folders, and the new app does not appear to have the ability to do that. I've never found another File Explorer that is capable of accessing these folders without first rooting the phone which I don't want to do, and I also really want to save some of these files that are now stuck in a folder I can't access.

    The old Files app still exists on my device under the All Apps section of settings, but the icon has been removed from the app drawer. What can I do to access the old Files app or at least the folders that the Files app was able to?

    Any help is greatly appreciated! Thank you.
    01-22-2019 07:56 PM
  2. Rukbat's Avatar
    ES File Explorer is the old standby. If it can't access a folder, that has nothig to do with Android, it's being hidden by Linux, and no Android app can get around that. (When the phone is rooted, Android is running as Superuser, so it has access to everything.) If you're talking about a folder like /data, there won't be anything in it unless the phone is rooted. Even a direct terminal app can't see anything in it - due to Linux. An app can't "get around" that.
    01-23-2019 12:26 PM
  3. B. Diddy's Avatar
    I'd stay away from ES, though. After it got bought by the people behind DU Battery Saver (they're on par with Cheetah Mobile as being terrible shady companies), they started loading it with useless junk and questionable practices. Personally, I like Total Commander, but that also won't let you look at system directories.
    Laura Knotek likes this.
    01-23-2019 04:06 PM
  4. Advaera's Avatar
    This is definitely a Google-ism.

    I tried ES File Explorer and it can't access the folder. But if I go to the Gmail app or Google Hangouts app and try adding an attachment then it will open the old Files app and can see that folder. But because it's in attachment mode the only thing it can do is send files small enough to fit in an email, it can't actually manage the files in the folder. Opening the full version of the Files app used to give me full management controls over these special Google folders to move and delete files stuck in there.

    I've tried a variety of File Browser apps including ES, and so far nothing has managed to even tell that this folder exists, but like I said, it's definitely there because it exists for attachments in Gmail and Hangouts.

    I've also tried to remove the Google Files Go app to make the system default to the old Files app again, but Files Go is now considered a "Systems App" and can't be uninstalled, only have its updates removed. Did that, Disabled it, restarted the device, I still haven't been able to make the old Files app launch in full mode. I have managed to make it the default app for attaching files in other apps for chats, social media, and email, which feels so close, if I could get it to default in something like Dropbox then I could upload my larger files out of it and be done, but all the cloud sync apps I'm aware of use their own file browser still can't see this folder.

    I'm sure it could very well be a Linux thing, it's driving me crazy though that only certain Google apps have permissions to access the folder while no other apps do.

    If you can think of anything else that might help please let me know. Thank you!
    01-23-2019 11:05 PM
  5. k1udge's Avatar
    If you plug a USB drive into the phone, you get the notification that you plugged it in. If you click the notification it will open the old Files app.
    05-10-2019 08:19 AM

Similar Threads

  1. Does the phone make a difference with Android Auto?
    By mikepfly2 in forum Android Auto
    Replies: 4
    Last Post: 02-06-2019, 11:48 AM
  2. Why can't I make inn-app purchases?
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 01-25-2019, 11:00 AM
  3. Why SMSBackup+ won't feed the most recent backup to my new phone?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-23-2019, 12:40 PM
  4. Alcatel A30 how to mirror or is it possible
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-22-2019, 05:50 PM
  5. What app has the white shirt with the black heart notification?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-22-2019, 05:50 PM
LINK TO POST COPIED TO CLIPBOARD