1. Android Central Question's Avatar
    Whenever I am in an area of poor service my S10 cannot use the internet or anything related to it when it is using a 4G network. Toggling airplane mode on and off sometimes causes it to switch to a 3G network which works perfectly.

    Is there a way to manually choose to stay on specifically a 3G and ignore 4G?

    Carrier is Verizon if that matters.
    03-20-2019 06:52 PM
  2. Tim1954's Avatar
    It should auto select whatever network is the strongest. Look in settings... Connections.... Mobile networks...
    You will see what your options are
    kct1975 likes this.
    03-20-2019 07:30 PM
  3. Frostwhisper21's Avatar
    It should auto select whatever network is the strongest. Look in settings... Connections.... Mobile networks...
    You will see what your options are
    It selects the 4G once peaks times are over, but generally my connection times out with 4G before any video or page can load. 3G works instantly on the other hand. This is true on my old S7 as well.

    My options are Global, LTE/CDMA, and LTE/GSM/UMTS. Switching kept it on 4G.

    Pretty sure my only option is to switch providers but I wanted to make sure if there was a work around or not, because I'm fine with the 3G.

    Thank you for your time.
    03-20-2019 09:52 PM

Similar Threads

  1. Why isnt my 4g working
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-21-2019, 01:44 AM
  2. Note9 via costco ... switching networks
    By Android Central Question in forum Samsung Galaxy Note 9
    Replies: 0
    Last Post: 03-20-2019, 06:44 PM
  3. Is there a way to get rid of new pop-up notifications?
    By SeekerAskar in forum General Help and How To
    Replies: 1
    Last Post: 03-20-2019, 05:09 PM
LINK TO POST COPIED TO CLIPBOARD