1. Android Central Question's Avatar
    Hello everyone. I've dropped my Galaxy S6 from my pocket today. When I picked it up, it was turned off. It wouldn't turn on, so I plugged it on the charger and it showed the charging icon, but stuck on a loop: It would show the icon, the phone would shut down, restart, show the icon, shut down again and again.

    I hard reseted it while plugged, and it was now showing the android logo, but doing the same loop as before.

    If I unplug the cable, it shuts down instantly. The only function I can access while plugged without the reboot loop is the custom OS install one. The phone stays there indefinitely, apparently working, but Odin does not recognize the phone, no matter what I do.

    I suspect something is loose inside, maybe the battery or a connector or smh. I've been reading that the OS install software does not depends on the system, so it probably somehow bypass the loose battery and gets energy directly from the cable...?

    Any help would be much appreciated!
    04-05-2019 06:36 PM
  2. belodion's Avatar
    Whatever it is, it's presumably internal damage of some kind. I don't think that we can diagnose that more precisely via a forum, alas.
    04-05-2019 06:46 PM

Similar Threads

  1. Saved contact info not showing on incoming calls
    By JHoldt in forum General Help and How To
    Replies: 9
    Last Post: 04-29-2019, 12:10 AM
  2. Why isn't android auto working on my vehicle?
    By ChloeandCassie1 in forum Android Auto
    Replies: 3
    Last Post: 04-25-2019, 06:58 PM
  3. How to root my phone useing framaroot or kingroot on Motorola 5
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 04-05-2019, 08:54 PM
  4. Replies: 1
    Last Post: 04-05-2019, 08:42 PM
  5. I accidentally clicked deny on my hangouts microphone.
    By Sue Bean in forum General Help and How To
    Replies: 1
    Last Post: 04-05-2019, 07:01 PM
LINK TO POST COPIED TO CLIPBOARD