1. Android Central Question's Avatar
    So I update my Razer Phone 2 to Android Pie and everything seems to be working fine, but for some reason on random occasions I cannot charge my phone neither from the original USB-C cable or their Wireless RGB charger. When I place the phone on the wireless charger it lights up detects the phone is there and I have lights set to show when it's charging. The lights show, but the phone doesn't charge. When I plug the phone into the USB-C port nothing happens, but when I drop down the menu from the top of the screen I see a USB notification. I click it and it shows USB Preferences are set to give control to the connected device. There is an option to switch it to give control to 'This Device'. When I chose that it hangs for a bit and then says can't switch.

    If I reset the phone it works for a while then problems repeat. I've tried going into developer mode and playing with settings. I've factory reset my phone too and problems reoccurred.

    What is going on?!
    05-18-2019 03:05 AM
  2. Rukbat's Avatar
    Which version of Android is it running?
    05-18-2019 12:41 PM
  3. Herbalacious's Avatar
    Thanks for responding!

    Using android pie.

    I came across a forum post somewhere else where multiple phones of various versions of android having the exact same issue. The 'solution' was to power off the phone, plug it into a pc and turn the phone on, swap between charge only and file transfer a few times in the USB preferences. I'm not sure if it works yet..if the phone charges normally during normal use over the next 48 hours then I'd say it worked. I don't have an option for 'charge only' but am pretty sure that 'this device' is the same option for that. So I swapped between 'this device' and 'file transfer' a few times. I also put in a support ticket to Razer. I'll update as things go along.
    05-18-2019 06:24 PM
  4. methodman89's Avatar
    Are you getting to make a selection on this screen pictured?
    05-19-2019 12:43 AM
  5. Herbalacious's Avatar
    Yeah that's the USB preferences. Only my choices are a bit different. On the top it will say something like the USB is controlled by: and then there are 2 options 'Connected Device' and 'This Device'. Then underneath those 2 settings there's a line and under the line a few more options that include PTP, File transfer, MIDI, etc. I'm 99% sure 'This Device' is the same as 'Charge this Phone' option on your list.

    It will only show those 2 options on the top if there is something plugged into the USB-C port. So I plug in the charger, it detects that I plug in the charger to the port, but no charge. Dropping the pull down menu from the top screen will show a USB notification. USB controlled by connected device. Tapping that notification will send me to the preferences screen. Trying to change it to 'this device' fails. That's the default setting it needs to be on to charge.

    I've tried charging the phone while it was off..worked fine and it just charges like normal. Weird.

    So the weird magic trick I posted earlier by plugging into the PC and playing with the USB preferences is working? For some reason today I didn't have to reset my phone lol. Fluke or some kinda of android-pc magic?

    I still doubt that it will work and am expecting the problem to repeat by the time I get off work tomorrow.
    05-19-2019 03:13 AM
  6. Herbalacious's Avatar
    So I think the phone has faulty hardware. It happened again today out of no where my phone just wouldn't stop beeping and it was the notification for USB. I drop it down it shows 'Connected Device Charging via USB' when nothing is plugged into it. A quick search for that shows lots of people with various phones on different versions of android that have the same problem. This pretty much seals the deal for me that it's a hardware issue and have requested an RMA. Bummer cus the phone works really good..when it's working.
    05-20-2019 06:33 PM
  7. Gregg Cannella's Avatar
    I'm having the same problem and I have a Samsun S9

    it defaults to USB controlled by: "Connected device", and I have to manually switch it to "This phone" if I want it to charge.
    08-05-2019 02:38 PM

Similar Threads

  1. So how are the Otterbox for this compared to older models?
    By JnEricsonx in forum Samsung Galaxy Note 8
    Replies: 5
    Last Post: 05-19-2019, 12:14 AM
  2. Why do i have 24GB on my phone when i am supposed to have 32GB?
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-18-2019, 02:13 AM
  3. how to close es swipe mode in samsung note 8
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-18-2019, 02:10 AM
  4. Replies: 1
    Last Post: 05-17-2019, 11:12 PM
  5. My gmail will not accept password need to reaet
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-17-2019, 10:54 PM
LINK TO POST COPIED TO CLIPBOARD