1. Android Central Question's Avatar
    Hello, i have a mobile device android from 2015, it's a vodafone 890N its 4 years old but i want to update it to at least version 5.0 or higher, in order to play pokemon go, what can i do?
    I tried to do the system detection to update but it's no longer updating my device, it says it's updated.
    But this version wont let me open pokemon go
    07-05-2019 11:03 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! System updates are dependent on the manufacturer and the carrier. Most manufacturers only support a phone with system updates for about 18-24 months, and typically only for flagship phones. Budget phones are lucky to get even one update for security patches.

    You'll probably just have to look into getting a more modern phone if you want to play Pokemon Go.
    hallux likes this.
    07-05-2019 11:29 AM

Similar Threads

  1. Replies: 8
    Last Post: 07-06-2019, 08:38 AM
  2. Is my software updated or not?
    By RebekahJP in forum Samsung Galaxy S7
    Replies: 4
    Last Post: 07-05-2019, 11:09 PM
  3. Camera is useless after pie update
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 07-05-2019, 11:46 AM
  4. Green box appears. This is such a schlep. Why have this feature?????
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 07-05-2019, 11:34 AM
LINK TO POST COPIED TO CLIPBOARD