1. Android Central Question's Avatar
    Hi. I have a new Samsung A7, have inserted my existing SIM and am trying to access my Google account to transfer all data. I complete the authentication, the screen 'thinks' for a while then tells me my account is not recognised by Google.....for the umpteenth time. I have not recently changed my Google password. I'm using a secure and strong internet connection
    What do I do now?
    Please help. Thank you so much
    Christina 🤗
    08-19-2019 02:04 PM
  2. mustang7757's Avatar
    Hi, welcome to Android Forums

    I'd like to recommend creating a account so me or other members can assist you, as guest have limitations in replying here and if we need further Information to communicate with you.

    I'll provide a link to register, please come back to your post so we can further assist you . Thank you

    https://forums.androidcentral.com/sh...d.php?t=409154
    08-19-2019 02:27 PM
  3. mustang7757's Avatar
    Try going on the web and enter your Google I'd and password see if it works there
    08-19-2019 02:27 PM
  4. B. Diddy's Avatar
    Welcome to Android Central! Are you certain this is a brand new phone, and not used? If it were used and the previous owner didn't properly remove their Google account prior to factory resetting, then it'd be asking for the previous person's Google account and password (as part of Factory Reset Protection).
    08-19-2019 02:45 PM

Similar Threads

  1. Replies: 1
    Last Post: 08-19-2019, 12:20 PM
LINK TO POST COPIED TO CLIPBOARD