1. lonutzz's Avatar
    Hello,
    I recently bought a new TP Link router Archer C6, I used the usual steps to connect it to my PPPoe connection, and everything went smooth. Nice speeds on download/upload, on both: cable and wifi.

    Despite this, I am having a curious problem. When I'm connected to the router via Wifi with my android devices, the apps won't update anymore. I have 2 mobile phones, and 2 tablets, and the problem is the same to all of them - Apps in play store won't update. I even tried to update some apps manually, but still no success. As soon as i switch to mobile data, or I use someone else's wifi, everything is back to normal.

    In all this time, the internet works fine on these android devices, on every website I tried, youtube, netflix, absolutely no problem. Just that the apps in play store won't update.

    Had somebody have this weird issue? What should I do? I had never experienced something similar.

    Thanks a lot.
    10-09-2019 01:17 PM
  2. Rukbat's Avatar
    [moving to Ask a Question for better exposure]

    Check the WiFi encryption in the router. If it's TKIP or TKIP+AES, change it to AES.

    (And please don't post more than once.)
    10-09-2019 01:41 PM
  3. jameny5's Avatar
    It sounds like a misconfiguration of your settings. Reconfigure your router. Then enter your ssid, Wep security and password. Or: check the Google Play Store app in settings. Clear the cache and restart the play store. I also read somewhere awhile ago to clear the cache of downloads. I don't know where it is housed on the phone. You have to search around a bit. Or visit techkhoji.com/no-connection-retry-google-play-store/
    10-09-2019 01:56 PM
  4. B. Diddy's Avatar
    Duplicate threads merged.

    See this guide for other ideas: http://forums.androidcentral.com/amb...-problems.html
    10-10-2019 12:07 PM

Similar Threads

  1. Article about IMEI vulnerability on Android phones
    By robinhelenehebert in forum Android 10
    Replies: 6
    Last Post: 10-10-2019, 06:39 PM
  2. Touch not working on Galaxy S6 Edge SM-G9250 (Custom Rom)
    By Android Central Question in forum Samsung Galaxy S6 edge Rooting, ROMs, & Hacks
    Replies: 5
    Last Post: 10-09-2019, 05:08 PM
  3. Does Anyone know what app this symbol is for?
    By 1musicLover1982 in forum Ask a Question
    Replies: 2
    Last Post: 10-09-2019, 01:04 PM
  4. Touch not working on Galaxy S6 Edge SM-G9250 (Custom Rom)
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-09-2019, 12:24 PM
LINK TO POST COPIED TO CLIPBOARD