12-01-2019 05:45 PM
32 12
tools
  1. mattc1990's Avatar
    I bought an LGV20 2 years ago from newegg, the phone was unlocked but always displayed an AT&T logo when booting up, I put my prepaid T-mobile sim in and everything was fine. Last week (2 years to the day since I purchased the phone), I suddenly got a notification of no signal. After going to my local T-mobile store, they told me that the phone had become locked to AT&T again. Does anyone have any ideas on how to fix this?
    11-30-2019 08:27 PM
  2. mustang7757's Avatar
    Did you buy the unlocked version or had Att unlock it ? I'll leave a link to register so you can communicate here, as a guest account u cant .https://forums.androidcentral.com/sh...d.php?t=409154
    11-30-2019 08:33 PM
  3. mattc1990's Avatar
    Hi, thanks for the link to sign up. I bought the phone from Newegg, which was described as unlocked an operated as such, however it does show the AT&T logo when it boots up.
    mustang7757 likes this.
    11-30-2019 08:38 PM
  4. mustang7757's Avatar
    Hi, thanks for the link to sign up. I bought the phone from Newegg, which was described as unlocked an operated as such, however it does show the AT&T logo when it boots up.
    Hi ,welcome!
    Hmm...usually unlocked phones wont have a carrier splash screen , so when you insert the tmobile sim it doesn't say sim locked ?
    11-30-2019 08:41 PM
  5. mattc1990's Avatar
    It just tells me no service, ive ensured that my service through t-mobile is active and it is. I have found that the IMEI is nulled. The person I spoke to at t-mobile told me that the phone had been relocked, probably after an update (I am not aware that any update occurred). It doesnt tell me sim locked though. I just find it odd that its worked fine for two years up to this point. Ive also checked and the sim is fine and works in other phones.
    11-30-2019 08:45 PM
  6. mustang7757's Avatar
    It just tells me no service, ive ensured that my service through t-mobile is active and it is. I have found that the IMEI is nulled. The person I spoke to at t-mobile told me that the phone had been relocked, probably after an update (I am not aware that any update occurred). It doesnt tell me sim locked though. I just find it odd that its worked fine for two years up to this point. Ive also checked and the sim is fine and works in other phones.
    Yeah this is strange , but one place to check is see if it populated a APN for tmobile and its highlighted as in use like a dot next to its name
    11-30-2019 08:49 PM
  7. me just saying's Avatar
    did you check with at&t to see what they say? if you don't want to talk to them directly, they do have a community forum at their site.
    11-30-2019 08:54 PM
  8. mattc1990's Avatar
    Thank you to both of you, Ill contact AT&T in the morning, and post to their community, and im currently charging the device to check the APN.
    mustang7757 likes this.
    11-30-2019 08:59 PM
  9. mattc1990's Avatar
    Am i Correct in thinking APN would be under mobile network, if that is correct, mobile network is greyed out from settings
    11-30-2019 09:22 PM
  10. mustang7757's Avatar
    Am i Correct in thinking APN would be under mobile network, if that is correct, mobile network is greyed out from settings
    Yes it would be , have you tried to restart the phone after putting the sim ?
    11-30-2019 09:26 PM
  11. mattc1990's Avatar
    I have, multiple times, with no success. Ive checked a few forums and think the issue is the IMEI being null-null, however im struggling to find a fix for this.
    11-30-2019 09:27 PM
  12. mustang7757's Avatar
    I have, multiple times, with no success. Ive checked a few forums and think the issue is the IMEI being null-null, however im struggling to find a fix for this.
    Yeah from the sound of it I think you have a carrier locked phone ,best bet contact Att and see from their system
    11-30-2019 09:29 PM
  13. mattc1990's Avatar
    Thanks for your help, im just confused at how this would be fine for 2 years, and now its suddenly a problem
    11-30-2019 09:35 PM
  14. mustang7757's Avatar
    Thanks for your help, im just confused at how this would be fine for 2 years, and now its suddenly a problem
    You used different Sims before this ? Your welcome!
    11-30-2019 09:41 PM
  15. mattc1990's Avatar
    I got a free replacement sim today, to ensure that the sim wasnt the problem, but apart from that no, always had the same sim.
    11-30-2019 09:44 PM
  16. mustang7757's Avatar
    I got a free replacement sim today, to ensure that the sim wasnt the problem, but apart from that no, always had the same sim.
    So it could of been locked all this time you didn't know.
    11-30-2019 10:03 PM
  17. mattc1990's Avatar
    Would that work though as its assigned to AT&T and ive used a t-mobile sim the whole time?
    11-30-2019 10:05 PM
  18. mustang7757's Avatar
    Would that work though as its assigned to AT&T and ive used a t-mobile sim the whole time?
    Oh sorry misunderstood , thought u had Att sim and just went to TMobile
    11-30-2019 10:05 PM
  19. mattc1990's Avatar
    No worries, that is why im confused, I dont quite understand how I could have used the same sim for 2 years with no problem and then my IMEI gets nulled. Ill call AT&T in the morning, but im not sure how much they can help as Ive never been their customer.
    mustang7757 likes this.
    11-30-2019 10:10 PM
  20. mustang7757's Avatar
    No worries, that is why im confused, I dont quite understand how I could have used the same sim for 2 years with no problem and then my IMEI gets nulled. Ill call AT&T in the morning, but im not sure how much they can help as Ive never been their customer.
    Yeah that is strange, but since it's a att device maybe they can give you info is phone unlocked or black listed , see what they say , I'm almost 100 percent TMobile not going help especially a device not from them .
    11-30-2019 10:17 PM
  21. Mike Dee's Avatar
    No worries, that is why im confused, I dont quite understand how I could have used the same sim for 2 years with no problem and then my IMEI gets nulled. Ill call AT&T in the morning, but im not sure how much they can help as Ive never been their customer.
    They sold you a carrier branded phone that was carrier unlocked so it worked fine. So now somehow AT&T locked it or something else is wrong.
    11-30-2019 10:38 PM
  22. mattc1990's Avatar
    Hi Mike, thanks, I didnt realize that AT&T could lock it again, ill call them tomorrow and see what happens. I am actually leaving the US in 3 weeks so getting it unlocked again is really important as AT&T isnt a supplier in the UK where im going
    11-30-2019 10:42 PM
  23. Mike Dee's Avatar
    Hi Mike, thanks, I didnt realize that AT&T could lock it again, ill call them tomorrow and see what happens. I am actually leaving the US in 3 weeks so getting it unlocked again is really important as AT&T isnt a supplier in the UK where im going
    I don't think they did but anything is possible.
    11-30-2019 11:09 PM
  24. Mike Dee's Avatar
    I went back and looked at some of your posts. I'm not sure that Mobile Networks should be greyed out even if it were carrier locked. You should still be able to get into the setting.
    11-30-2019 11:13 PM
  25. mattc1990's Avatar
    Thanks Mike, any advice is appreciated, t-mobile were also expecting mobile networks to be accessible
    11-30-2019 11:37 PM
32 12

Similar Threads

  1. Accidentally disabled G board on my android TCL
    By Android Central Question in forum Ask a Question
    Replies: 7
    Last Post: 12-01-2019, 05:39 PM
  2. Has anyone found another application that works for the Galaxy note 9 VoLTE?
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 12-01-2019, 12:08 PM
  3. Why is my S6 phone grayed out for an app after resetting to factory defaults
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-30-2019, 07:36 PM
LINK TO POST COPIED TO CLIPBOARD