1. Android Central Question's Avatar
    i was trying from 5 minutes. sudden I get burning smell. i have huwaei y3 2017. now it is working perfect but not connect to any charger why? is this AC has burnt? or it has issue with charging pin?
    01-20-2020 02:09 PM
  2. Mooncatt's Avatar
    You have a lose connection causing a short somewhere. I personally wouldn't use the phone until you can take it, the cable, and charger to a shop for a proper evaluation. You are posing a fire risk if you keep trying to use it.
    Rukbat likes this.
    01-20-2020 03:31 PM
  3. mustang7757's Avatar
    I agree , for safety have it looked at .

    I'll leave a link to register so you can communicate here, as a guest account u cant .

    https://forums.androidcentral.com/sh...d.php?t=409154
    01-20-2020 03:39 PM
  4. B. Diddy's Avatar
    Welcome to Android Central! I agree with the above, but would also suggest inspecting the phone's port as well as the plug to see if there's any debris in there.
    01-21-2020 01:40 PM

Similar Threads

  1. Replies: 3
    Last Post: 01-23-2020, 02:40 PM
  2. Replies: 8
    Last Post: 01-21-2020, 02:52 PM
  3. What is this icon and why won't it go away!?!?!?!
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 01-21-2020, 02:12 PM
  4. Replies: 5
    Last Post: 01-21-2020, 01:10 PM
  5. phone went from 34% to 0% in less than a minute.
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-20-2020, 04:47 PM
LINK TO POST COPIED TO CLIPBOARD