1. Android Central Question's Avatar
    I have a huawei P smart running EMUI 9.1.0, Android 9. I had no issues until I reset the device the other day to restore my old wifi networks, and now suddenly I'm reciving no push notifications (it's not a setting I forgot to enable or disable, as I made a backup of my system settings using the Huawei backup feature and then restored it after reset).
    I toubleshooted this and was given the solution of going to settings, battery, app launch - and from there enabling auto launch, secondary launch and run in background on all apps (which I've now done)
    I was also advised to go to apps, special access, battery optimisation, and from there mark all apps as "allowed" (to bypass battery settings which might prevent them from being allowed to send notifications). These were all the troubleshooting steps available and I've done them all with little success (gmail and google play are notifying me now, but other apps such as youtube, facebook messenger, discord etc aren't despite also being marked as allowed)
    Is there anything I can do? Huawei customer service wan't helpful either
    01-27-2020 04:04 PM
  2. mustang7757's Avatar
    Double check notifications are on or go through settings sometimes they dont get transferred .

    I'll leave a link to register so you can communicate here, as a guest account u cant .
    https://forums.androidcentral.com/sh...d.php?t=409154
    01-27-2020 04:07 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Does it work for preinstalled apps if you boot into Safe Mode? https://www.getdroidtips.com/boot-hu...art-safe-mode/
    01-27-2020 04:09 PM
  4. cfaulkner3142342's Avatar
    I have double checked... are there really no other options than that?
    01-27-2020 04:26 PM
  5. cfaulkner3142342's Avatar
    Welcome to Android Central! Does it work for preinstalled apps if you boot into Safe Mode? https://www.getdroidtips.com/boot-hu...art-safe-mode/
    Fom my understanding this is a way to determine if any of your installed apps are causing issues, however I don't have any different apps than I did before I reset, could this still be a solution worth investigating given this?
    01-27-2020 04:29 PM
  6. mustang7757's Avatar
    I have double checked... are there really no other options than that?
    Hi , welcome!
    Something might of got messed up on the transfer of setting , go into settings>apps>3 dots upper right corner tap >reset app preferences should reset all apps settings to default
    01-27-2020 04:34 PM
  7. cfaulkner3142342's Avatar
    Hi , welcome!
    Something might of got messed up on the transfer of setting , go into settings>apps>3 dots upper right corner tap >reset app preferences should reset all apps settings to default
    Thank you for your help! Unfortunately it didn't work
    Any other possibilities?
    mustang7757 likes this.
    01-27-2020 04:47 PM
  8. mustang7757's Avatar
    Thank you for your help! Unfortunately it didn't work
    Any other possibilities?
    In settings maybe under general do you have the option to reset settings , some have this others not ?
    01-27-2020 04:49 PM
  9. cfaulkner3142342's Avatar
    In settings maybe under general do you have the option to reset settings , some have this others not ?
    I've just checked all my settings; one app that's having issues (discord) seems to be showing the issue - if I go into battery usage after closing it it says "33.36% (of battery used)... stopped" ("stopped" implying it's not running anymore now it's in the background, hence no notifications)
    However, in app launch "run in background" for it is enabled... any ideas?
    01-27-2020 04:54 PM
  10. mustang7757's Avatar
    I've just checked all my settings; one app that's having issues (discord) seems to be showing the issue - if I go into battery usage after closing it it says "33.36% (of battery used)... stopped" ("stopped" implying it's not running anymore now it's in the background, hence no notifications)
    However, in app launch "run in background" for it is enabled... any ideas?
    You can clear data ,cache and force stop it and if sync on it will repopulate the info into the app
    01-27-2020 05:01 PM
  11. cfaulkner3142342's Avatar
    You can clear data ,cache and force stop it and if sync on it will repopulate the info into the app
    Excellemt, thank you for your time and help!
    mustang7757 likes this.
    01-27-2020 05:07 PM
  12. mustang7757's Avatar
    Excellemt, thank you for your time and help!
    Your welcome!
    01-27-2020 05:09 PM
  13. B. Diddy's Avatar
    Fom my understanding this is a way to determine if any of your installed apps are causing issues, however I don't have any different apps than I did before I reset, could this still be a solution worth investigating given this?
    Safe Mode is a simple troubleshooting step, without any risk of data loss. It's always possible that after the reset, the reinstallation of apps might have included some app update that you weren't previously aware of (or were consciously trying to avoid) that is now causing issues with the system. If you boot into Safe Mode and you get push notifications from preinstalled apps, then you know that some app you installed is causing the problem, and the next step(s) would be to uninstall apps one by one until the problem goes away. If the problem persists in Safe Mode, then you know it has more to do with the system.
    01-27-2020 05:52 PM

Similar Threads

  1. Why is my light blue
    By Android Central Question in forum LG Stylo 4
    Replies: 2
    Last Post: 01-27-2020, 03:53 PM
  2. Note 4 No Sound/Vibration Notifications
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-27-2020, 03:52 PM
  3. Why can't i install Facebook messenger on my samsung S5
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-27-2020, 03:51 PM
  4. Why is my light blue
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-27-2020, 03:46 PM
  5. Replies: 1
    Last Post: 01-27-2020, 11:27 AM
LINK TO POST COPIED TO CLIPBOARD