1. jordo487's Avatar
    I just got a new prime int he mail and it has been charging for about an hour now and will not turn on yet. The little light on the power button is red. How long does it take them to charge for the first time to be able to turn them on? I am anxious!!!!!
    01-26-2012 07:46 PM
  2. jordo487's Avatar
    And when I press the power button, it blinks at me 3 times, then goes solid again.
    01-26-2012 08:19 PM
  3. kev83202's Avatar
    Mine turned on and had 40% battery out of the box, my brother had to plug his in for over an hour before his would turn on we thought it was a dud. I'd say somethings wrong after 2 hours though.
    01-26-2012 08:37 PM
  4. TekNinja81's Avatar
    Are you just clicking the button quickly, or holding it? I'm not sure about the blinking 3 times thing, never noticed that on mine, but you do have to hold the button for a second or so for the tablet to turn on.

    If that doesn't work, something's definitely wrong, return the unit.
    01-26-2012 08:37 PM
  5. jordo487's Avatar
    I held it down for a few seconds and then would get the blinking light. I call Asus and they told me to send it back for repair or return it. Awesome, finally get the thing and I get a broken one. Now I have no Prime for who knows how long. Very sad frustrating day.
    01-26-2012 09:34 PM
  6. TekNinja81's Avatar
    Have to say, it's unsettling seeing how many of these units seem to have shipped with defects/software issues. My experience with ASUS has generally been good, they've had a fairly high quality standard over the years, but clearly their venture into the tablet market has been rocky at best so far.

    I'm considering myself lucky that software problems (app crashing/rebooting) seem to be my only issues as of yet, but that said, still debating returning it and waiting until their 2nd generation has come out and ICS is fixed up... hard to really say whether the issues are truly just software, or hardware as well.
    01-26-2012 09:38 PM
  7. Jonneh's Avatar
    Have to say, it's unsettling seeing how many of these units seem to have shipped with defects/software issues. My experience with ASUS has generally been good, they've had a fairly high quality standard over the years, but clearly their venture into the tablet market has been rocky at best so far.

    I'm considering myself lucky that software problems (app crashing/rebooting) seem to be my only issues as of yet, but that said, still debating returning it and waiting until their 2nd generation has come out and ICS is fixed up... hard to really say whether the issues are truly just software, or hardware as well.
    The problem with your statement is, this is their second generation already lol. Millions of us said the exact same thing last time when the original Transformer came out "wow, there is such an insane amount of problems out there, I think I'll wait until ASUS gets their act together with the second generation that's sure to come out someday".

    For you, if you do return it and call it quits, you'll be waiting for the 3rd generation Transformer. :-P

    edited to add: Well, I guess you could be talking about the 701 or whatever, but I wouldn't call it a generational leap if it's a month later and is the same thing but with a plastic area on top for reception, higher res screen, and $100 more expensive.
    01-27-2012 08:59 PM
  8. totfit's Avatar
    I had no issues and have none. Got mine yesterday, but got the dock the day before. Plugged them in together and started them up immediately, connected to my wifi and about an hour later got ICS and other firmware upgrades.
    01-27-2012 09:21 PM
  9. jordo487's Avatar
    I lucked out and a couple BB stores got some in stock yesterday and I was able to exchange it! And I forgive the first dead Prime because it is AWESOME! Glad I got it!
    01-28-2012 09:30 AM
  10. jbfuson's Avatar
    Mine was dead oob too. Light was orange though. Chargedit for maybe 2 hrs and it came on.

    Sent from my Transformer Prime TF201 using Tapatalk
    01-28-2012 09:54 AM
LINK TO POST COPIED TO CLIPBOARD