1. jbalsbaugh's Avatar
    I opened up Google Maps today on my ASUS Eeepad (201) and it was continuously refreshing to the point of being unusable.

    Very frustrating. Can't find much if anything on line, especially recently. It's an app I use a lot.

    Anyone else having the problem? Cold start did not repair. Considering a data wipe and total reboot to fix if I can't find any other option.
    04-19-2013 07:10 AM
  2. B. Diddy's Avatar
    Weird. Try clearing the cache and/or data under Settings/Apps.
    04-19-2013 11:27 AM
  3. B. Diddy's Avatar
    Wonder if this had anything to do with it:

    Google outages this week blamed on sign-in system | PCWorld
    04-20-2013 12:11 AM
  4. Angela Franklin's Avatar
    I am seeing the same issue on my HTC DNA. I uninstalled the updates, reinstalled updated, rebooted, cleared cache, everything. Not sure why it keeps refreshing and is useless right now. I even removed the last 3 apps I recently installed. HELP I need to use my Google maps.
    04-22-2013 04:34 PM
  5. Chuck_D's Avatar
    I am experiencing the same issue on my Galaxy S3. It is very annoying, it has rendered Local unusable.
    04-23-2013 11:43 AM
  6. Ken Van Camp's Avatar
    I had this happen once before and I followed the suggestions to clear the tile cache and it worked. This week it happened again and clearing the cache didn't help so I went searching for answers, and didn't find any. So I finally I went to "Manage Applications", selected the Map application, and clicked Update to get the latest version. It downloaded a new version and now the problem is gone! So I don't know if it's a bug that Google fixed, or if the simple act of updating cleared some setting or cache that fixed it, but at least it's resolved (for now).
    12-03-2013 06:57 AM
  7. Mark Fisher1's Avatar
    This has been a problem I have been experiencing for a while. It only occurs when I go to google maps from a google search, so I have been circumventing the problem up to now by going directly to google maps and then searching within google maps to get to the location I wanted.

    I finally decided to get to the bottom of the problem. I deleted my data in Chrome (went a little overboard and deleted everything apart from saved passwords, so I'm not sure what in particular the culprit was). This solved the problem for me.

    As a nice little touch of irony I'm experiencing a similar problem with this site...

    Update: Wow, that didn't last long. About 5 minutes later and the problem is back. Clearing my data did work again though.
    04-24-2016 11:52 AM

Similar Threads

  1. Google Maps Navigation for 1.6
    By Kuth70 in forum Android Apps
    Replies: 17
    Last Post: 11-13-2015, 03:17 AM
  2. Google maps problems on Eris
    By Bobloblaw in forum HTC Droid Eris
    Replies: 1
    Last Post: 11-22-2009, 10:37 PM
  3. Google maps problems on Eris
    By Bobloblaw in forum Motorola Droid
    Replies: 1
    Last Post: 11-22-2009, 10:11 PM
  4. google maps not getting correct current location
    By craigpicc in forum Samsung Moment
    Replies: 1
    Last Post: 11-16-2009, 04:36 AM
  5. Google Maps & Transit Question on Moment
    By meballard in forum Samsung Moment
    Replies: 0
    Last Post: 11-11-2009, 11:20 PM