1. mrbill187's Avatar
    I just received my Transformer tonight, everything looks great so far, but i think i am having some problems with the power adapter. It has this strange secondary piece that snaps in and this is where the prongs come out from. Is this piece not supposed to snap all the way down? seems like it is not flush with the edge.

    If you are an owner, can you comment on this? Seems like ive had it plugged in for 40 min and its not charging (presumably because of problem with the adapter).

    Also.. is there any type of indicator or LED or charging screen to indicate it is working?
    05-16-2011 09:12 PM
  2. mrbill187's Avatar
    so it looks like i was being too gentle with it. i gave the adapter a good whack and it snapped all the way in,
    05-16-2011 09:35 PM
  3. Visual360's Avatar
    LOL. Yes, that thing needs a whack to snap all the way. I don't believe there is an LED indicator. I use circle widget on my screen to see the status, or you can just go to settings. I know, it would've been great with the LED.
    05-16-2011 10:27 PM
  4. FHSPSU67's Avatar
    There is a charging LED on the left side of the keyboard/dock.
    05-17-2011 05:55 AM
  5. jerrykur's Avatar
    I just received my Transformer tonight, everything looks great so far, but i think i am having some problems with the power adapter. It has this strange secondary piece that snaps in and this is where the prongs come out from. Is this piece not supposed to snap all the way down? seems like it is not flush with the edge.
    Where are you located? I am in the US and the charger came with the plug already attached. I am wondering if this is something they do for the US model, or perhaps I have a different batch.
    05-17-2011 10:23 AM
  6. IIJBII's Avatar
    Where are you located? I am in the US and the charger came with the plug already attached. I am wondering if this is something they do for the US model, or perhaps I have a different batch.
    I'm in the US and my charger was not together.
    05-17-2011 03:36 PM
  7. ragebunny's Avatar
    Ahaha i has the same problem, i was thinking it was going to break if i push it anymore, but turns out it does need a good whack!
    05-17-2011 04:15 PM
LINK TO POST COPIED TO CLIPBOARD