1. androidASUS's Avatar
    I believe there was a way to uncheck ASUS keyboard in input method and just have the default android keyboard. However, that option is greyed out for me.

    I have installed a bunch of keyboards which I think what caused this issue. I also updated to 3.1 so I'm not sure what caused this or I am dreaming and that option was always greyed out.

    Can somebody please check input methods and verify if they can be checked off. If so, what can I do to disable ASUS keyboard?

    Thanks!
    06-05-2011 03:12 PM
  2. stearic's Avatar
    when you go to type in a field, there will be a lil icon on the bottom right that looks like a keyboard. Select that and then you will have the option of what you want to use for your input method.
    Clariissa likes this.
    06-05-2011 04:17 PM
  3. jon_stewart's Avatar
    It does appear that there may be an issue automatically switching between ThumbBoard Keyboard and the Physical keyboard when the dock is attached / removed. I'm nearly sure this is only with 3.1.
    06-05-2011 05:41 PM
  4. androidASUS's Avatar
    No, I am talking about disabling the ASUS virtual/on-screen keyboard. No dock. When you go to configure input methods: You will have ASUS Keyboard (checked) and android keyboard (checked). The option to disable ASUS Keyboard in input methods is greyed out.

    What I would like to know: is it actually greyed out for everybody or just me?

    I believe I had the option to disable or uncheck ASUS keyboard on 3.0.1 but I have installed a bunch of keyboard and uninstalled them which may led to trigger this behavior.

    Thanks!
    06-05-2011 06:32 PM
  5. Suntan's Avatar
    Just tried switching between the asus and the defult keyboard on mine. Switches just fine.

    -Suntan
    06-05-2011 10:18 PM
  6. jon_stewart's Avatar
    I'll make it real simple for you. There may be a number of bugs relating to switching keyboards in 3.1. I did not misread your post.

    ...and yes, Asus and Android keyboards are greyed out for me too.
    Jon
    06-06-2011 01:39 AM
  7. androidASUS's Avatar
    I'll make it real simple for you. There may be a number of bugs relating to switching keyboards in 3.1. I did not misread your post.

    ...and yes, Asus and Android keyboards are greyed out for me too.
    Jon
    Thank you! Was it always like that even before 3.1?


    Screenshot just to clarify:
    http://i.imgur.com/cUChw.png
    06-06-2011 03:27 AM
  8. jon_stewart's Avatar
    I'm not absolutely sure about that, but I think it may have been. It certainly should be at the discretion of the user as to which are active / installed or not.
    06-06-2011 03:58 AM
  9. tsmit50's Avatar
    Those of you having issues when docking, were you rooted?
    06-07-2011 08:20 AM
  10. bob smith's Avatar
    Mine is stock TF and keyboard, and it looks exactly like yours. I upgraded to 3.1 last night. I did not look at it when I was on 3.0.1. Good luck.
    06-07-2011 08:25 AM
  11. tsmit50's Avatar
    I was asking because I'm not having the issue. I keep Thumb Keyboard 4 as my default when not docked, and then when i do dock, i get the pop-up that says "Select Asus Keyboard to remain consistent while docked". I mouse over to the keyboard icon and select the Asus keyboard.

    While it does look darker, it lets me select it and then flashes "English" on the screen.
    06-07-2011 08:36 AM
  12. jon_stewart's Avatar
    ditto, tsmit50.

    You should be able to set your default keyboard (for both of us, thumb board), and then when the dock goes on, it automatically switches to the physical keyboard, and then when you remove the the dock it should switch back to your chosen on screen keyboard. Not the silly message we're both getting!

    Bug for sure, but may be a bug with thumb board.
    Jon
    06-07-2011 10:01 AM
  13. rockcrawler's Avatar
    ditto, tsmit50.

    You should be able to set your default keyboard (for both of us, thumb board), and then when the dock goes on, it automatically switches to the physical keyboard, and then when you remove the the dock it should switch back to your chosen on screen keyboard. Not the silly message we're both getting!

    Bug for sure, but may be a bug with thumb board.
    Jon
    It has never automatically switched from the user defined keyboard to the Asus keyboard when docked. It has always given you the prompt to please switch to the Asus keyboard when it is docked. Nothing else. It is up to the user to switch to the Asus keyboard manually (or via an app) for better compatibility with the dock.

    As for the OP, I am on 3.1 and have the option to choose wither the Asus Keyboard, Android Keyboard, Swiftkey and Thumb Keyboard. Your issue must be yet another bug in a long list of issues with the 3.1 update. Maybe if you are up for it try a factory reset? Not an ideal solution, but if the issue us a total inconvenience to you it might be worth it. Good luck!
    06-07-2011 11:35 AM
  14. androidASUS's Avatar
    I was wondering if I can disable any of the default virtual keyboards. I guess can not.

    I do not have a dock and thought I can use hacker's keyboard or thumb keyboard as the only one enabled.

    Thanks for the help!
    06-07-2011 02:58 PM
  15. mclarryjr's Avatar
    Mine are both grayed out too but to switch between them I just go into current input method and select whatever keyboard I want. And I think if you install a third party keyboard it will also show up in those options.
    06-07-2011 03:42 PM
  16. Clariissa's Avatar
    At Language & Input, my option for the Asus keyboard (Fonepad 7 LTE) has been greyed out so I am unable to deselect it - to select only Swype instead.
    11-18-2014 06:12 PM
  17. Clariissa's Avatar
    when you go to type in a field, there will be a lil icon on the bottom right that looks like a keyboard. Select that and then you will have the option of what you want to use for your input method.
    To stearic

    Thank you very much!
    This has saved me much data usage. I have an Asus Fonepad 7 LTE.

    I had to download Swype each time I restarted my phone after transferring my Swype data to my external SanDisk SDHC card. Choosing Swype in Language & Input in Settings did not work.

    However, as your post suggests, that little keyboard icon (mine appears on the top left-hand corner) which appears each time I type in a field, does the trick!
    11-18-2014 06:17 PM
  18. soleyya's Avatar
    hello i'm from malaysia ..
    i want to know how to find my asus zenfone 4 keyboard it's was disappear i can't massage anyone else . i to dont have zen ul apps .
    i dont know where there going
    please help me !
    11-05-2015 03:19 AM
  19. Chara the fallen wyatt pensol's Avatar
    Uh i just want to know how to make my keyboard a transformers one on my phone XD
    04-18-2016 05:33 PM
LINK TO POST COPIED TO CLIPBOARD