1. OldListener's Avatar
    I bought a Memo Pad HD7 a week or so ago after reading positive reports on this forum. I got it today and had nothing but trouble.

    I had lots of trouble getting the touch screen to respond consistently. Then I starting getting a message "Unfortunately, Launcher has stopped." when I clicked on the white circle on the home page to get to the page showing app icons. The first chat session with an ASUS support person went nowhere. He didn't read what I typed, gave incomplete instructions and then ended the session as I struggled to follow his instructions. The second chat session went little better. I got instructions to hold down the volume button before I pressed the power on/off button to start and that got me to a boot screen with several boot options in tiny type. The first attempt to boot in recovery mode didn't work; it came up in the usual way and had the same error message. The next time the tablet failed to boot at all. Dark screen, no response to the power button.

    I'm inclined to return the tablet to B&H and try a different manufacturer and model. I thought that I'd ask for advice here before giving up.

    12-11-2013 06:08 PM
  2. B. Diddy's Avatar
    Welcome to Android Central, and that's a bummer! Try the steps shown in this video, and when prompted, select "wipe cache partition" first. If that doesn't help, then do the same process again, and this time select "wipe data/factory reset."

    Caped Codder and ivonpik like this.
    12-11-2013 08:13 PM
  3. GMC MaXx's Avatar
    I ordered two for my kids. Both were wonkey out of the box. After a factory reset using the recovery menu, then checking system updates for the current software version, they have been great!

    Posted via Moto Galaxy X Nexus One 7s (2013)
    12-11-2013 10:32 PM
  4. OldListener's Avatar
    Thanks to both of you for the advice. However, as I dewscribed in my first post, my tablet doesn't come on at all. No way to get to the recovery menu.
    12-13-2013 03:13 AM
  5. B. Diddy's Avatar
    I'd suggest trying to pop off the back cover and checking all connections just like you can with the Nexus 7 (2012), but I can't find any YouTube videos showing how.
    12-13-2013 03:55 AM
  6. Darius Munteanu1's Avatar
    Excellent video!
    I managed to restore my tablet without any info on the display but with this video as step by step guide.
    12-16-2013 07:12 AM
  7. B. Diddy's Avatar
    Excellent video!
    I managed to restore my tablet without any info on the display but with this video as step by step guide.
    Glad it worked, and welcome to Android Central!
    12-16-2013 06:10 PM

Similar Threads

  1. cant establish connection to google play after reset?
    By Adam Ashby in forum Sony Xperia Z
    Replies: 6
    Last Post: 11-26-2014, 09:26 AM
  2. How do I get my Home Screen to look like this ?!
    By Don164 in forum General Help and How To
    Replies: 15
    Last Post: 12-25-2013, 11:45 PM
  3. Movings apps to SD card
    By droid4lyf in forum AT&T Galaxy Note 2
    Replies: 2
    Last Post: 12-12-2013, 12:57 AM
  4. How to access Nexus 4 with broken touchscreen
    By Cacphony in forum Google Nexus 4
    Replies: 0
    Last Post: 12-11-2013, 05:44 PM
  5. Totally Dead DNA
    By rpopkin in forum Verizon Droid DNA
    Replies: 5
    Last Post: 12-11-2013, 05:27 PM