1. wigwam3's Avatar
    On my Asus M173 Memo Pad 7, the Google Drive App takes many long minutes spinning wheels on loading a small (50Kb) spreadsheet, a .doc and a 2 page .pdf. The documents were uploaded from a Windows 8 PC, around 200 files for a total of a bit less than 100Mbytes. The App works fine on the same Google Drive on an old A13-MID tablet and a Rockchip RK31sdk Android TV Stick. Also, the Memo Pad 7 is fine loading the documents from Google Drive on Browser. Just this App hangs around for around 5 minutes doing nothing on the Memo Pad, then eventually does load the document quickly. Once loaded, it can be reloaded quickly. I had the problem on Android 4.2.1 and still have it after upgrading to 4.2.2. Is this a ploy by Asus to entice me to use their Cloud Storage? Any ideas please?
    02-12-2014 11:58 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! There might be some screwy bit of data stuck in the cache. Try going to Settings>Apps>All, select Google Drive, then Clear Cache. If that doesn't help, consider uninstalling all updates to Google Drive, then re-install the updates.

    It could also be some Asus-specific issue. I've noticed that my Asus TF300T takes a long time to sync Google apps. Not sure why.
    02-13-2014 12:48 AM
  3. wigwam3's Avatar
    Thanks B. Diddy
    I have cleared the cache, uninstalled Google Drive, closed the device down completely, reinstalled Google Drive and still have the same result. It may be an Asus specific issue as I have installed Explorer from Speed Software which has the ability to include Google Drive and I still have the same problem there. It does appear to be a bit quicker, but still spends minutes doing nothing, before loading the file. Then once loaded, it is immediate after that. I have loaded around 10 files, slowly, then any one of them will reload immediately until I close down the Memo Pad. Then when next I try, it is slow again. I bought the Memo Pad last week, so if it is an Asus problem, I still have the option of returning it for a refund. However, it is fine in all other respects.
    02-13-2014 02:21 AM
  4. B. Diddy's Avatar
    That's interesting. My Asus TF300 also has another app that can link to Google Drive (Polaris Office), so I wonder if that tends to slow things down. You could try uninstalling or disabling any other app that has access to Google Drive, and see if the sync speeds up afterwards.
    02-13-2014 02:37 AM
  5. wigwam3's Avatar
    Talk about great minds thinking alike. I have uninstalled both of the Apps and reinstalled each without the other to test and still got the same result. Although Explorer is a bit quicker than Google Drive, it is more indicative of the wait. Google Drive just spins it's wheels saying nothing then eventually it loads the doc. Explorer sits on 0% for a very long time, then races to 100% within a couple of seconds. Both do display the document eventually. I'm now of a mind that it is an Asus problem. I can probably live with it as I can download OK with Browser Google Drive, although I do have the option of returning the Memo Pad for another few days.
    B. Diddy likes this.
    02-13-2014 03:54 AM
  6. wigwam3's Avatar
    I have tried 2 other Explorer Apps that give access to Google Drive and they also stall for minutes before opening a small file. So, I have dropped Google Drive and I'm no using Dropbox with instant download. I am assuming that the Explorer Apps use the Google Drive App code in some way. So, there appears to be some conflict between Asus Memo Pad and Google Drive, but it no longer causes me a problem. Thanks for the suggestions B. Diddy
    B. Diddy likes this.
    02-14-2014 08:20 PM

Similar Threads

  1. Dropbox problem on SGS3
    By mgina283 in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 02-10-2014, 10:30 PM
  2. Replies: 8
    Last Post: 02-08-2014, 11:39 AM
  3. My contacts problem with Gmail
    By Abdullah Nasser in forum General Help and How To
    Replies: 1
    Last Post: 02-08-2014, 12:58 AM
  4. Having problems with 4.4.2 email app
    By randian in forum General Help and How To
    Replies: 0
    Last Post: 02-07-2014, 06:02 PM
  5. Moto x contacts problem
    By Bigpgs in forum Android 4.4 KitKat
    Replies: 2
    Last Post: 02-07-2014, 05:47 PM