1. tazwsk60's Avatar
    After taking option to download an upgrade, the screen seems to be stuck in a loop. I have the Android icon and the status bar goes so far then restarts. It's been doing this for 10 hours now. I have tried a reboot and I get the black Android screen, then it switches back to the android update screen. The only issue I had was that just after setting off the upgrade I got a message saying that the battery didn't have enough power to complete the upgrade, so I plugged it in, first via a USB cable into my PC, then into the mains. I've logged this with Asus, but if anyone has any ideas, I'd be grateful. I don't have an SD card to hand.
    02-23-2014 02:06 PM
  2. wfranckw's Avatar
    Hi Tazwsk60,
    I'm exactly in the same situation, i wanted to know if you solved your problem since you posted your message above.
    06-15-2014 12:08 PM
  3. ScottyAG's Avatar
    Do a factory reset on it.

    Here's how to do it.

    ยป How to Hard Reset the Asus Memo Pad HD7
    06-17-2014 08:15 PM
  4. triplexxx2070's Avatar

    I have exactly the same issue, did you find a solution?

    04-18-2015 03:40 PM

Similar Threads

  1. Zim to Neptune - New Game
    By kidturboa7x in forum Android Apps
    Replies: 1
    Last Post: 07-04-2014, 12:56 AM
  2. How to turn off text vibration when ringer is on- s3 mini
    By someone11 in forum Verizon Galaxy S III
    Replies: 9
    Last Post: 03-01-2014, 05:10 PM
  3. Swipedialer Pro Bug on KK?
    By Series335 in forum Motorola Droid MAXX
    Replies: 8
    Last Post: 02-27-2014, 10:02 AM
  4. How to put parental control on Android Chrome browser?
    By Metro1088 in forum General Help and How To
    Replies: 2
    Last Post: 02-23-2014, 08:47 PM
  5. Replies: 1
    Last Post: 02-23-2014, 01:56 PM