1. Batt4Christ's Avatar
    RCA Pro10 RCT6203W46 purchased last November. Has been a more reliable device than my previous ASUS MeMO Pad HD 7... until last night...

    Picked up device and hit the power button. It booted as usual. Soon after getting to the main home screen, a window came up notifying me of a Firmware update (I check the web and found that indeed, there is an update). So I tapped the button to approve. It began downloading, and a few moments later said it was going to reboot. Just as the screen was going off, I could just make out some notice with the word "error" in it... but of course could do nothing about it.

    Device begins to boot, then:

    http://i59.tinypic.com/120l5sp.jpg

    Dead Android, "Android system recover"

    It gives a list of options:
    reboot system now
    apply update from ADB
    apply update from cache
    wipe data/factory reset
    wipe cache partition
    backup user data
    restore user data

    None of which resulted in any improvement.

    I even tried the "restore user data", picking an older backup (when device was new). Nope. After reboot, still get the same screen. Not even selecting the factory reset option makes a difference.

    Additionally - the screen will not shut off. The only way to get it off was to stick a pin in the RESET hole on the back. (And that makes no difference either, as when you press the power button, and it goes through the RCA logo screen, it then goes right back to the same dead Android screen.)
    04-18-2015 05:28 PM
  2. B. Diddy's Avatar
    Tough situation. I'd try contacting RCA support, since it's their firmware update that seems to have caused the problem: https://rcasupport.zendesk.com/hc/en...317055-Tablets
    04-19-2015 02:28 AM
  3. foxposy's Avatar
    did u fix it?
    05-16-2016 03:39 PM
  4. droohr's Avatar
    I know it's been a year since this post, but this situation just happened to my son's rca pro 10 and I am at a loss to find an original rom to get it back running.
    05-20-2016 05:49 PM
  5. Dan Copeland's Avatar
    I was so happy wheni found this someone else with the exact issue as me.


    And then no love.......

    Anyone?

    I have adb sideload.... and usb drivers kinda working lol

    .....RCA You suck

    rct6203w46l boot loop, no custom recovery, dont know if it was rooted ( i was asked to check it out by someone and its their grand kids so who friggin know what happened)

    its saying android -v05-v1.9.20-d2 So I guess maybe an attempt to update.....

    I added a switch to the no removable battery, you cant get to recovery unless its completely off. and the only way to do that is remove the non-removable battery. meh it works... lol

    Ill let ya know what happens........
    06-15-2016 12:53 PM

Similar Threads

  1. Google Play Services Update
    By fritzo81 in forum Samsung Galaxy S6
    Replies: 65
    Last Post: 04-21-2015, 10:36 PM
  2. s5 new update 18.5.15
    By greatdj123 in forum Android 5.0 Lollipop
    Replies: 2
    Last Post: 04-19-2015, 04:18 AM
  3. How can I update my sm-n910v Note 4 from Verizon?
    By AC Question in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 04-18-2015, 11:22 PM
  4. Replies: 1
    Last Post: 04-18-2015, 06:05 PM
  5. HTC One T-Mobile Soft-Bricked (Can't Fix)
    By Fire2910 in forum T-Mobile HTC One
    Replies: 1
    Last Post: 04-18-2015, 05:25 PM
LINK TO POST COPIED TO CLIPBOARD