1. josearmz10789's Avatar
    Ok guys it now is day 3 with the zenfone 2 and for some reason the data is not working. Ive changed the APN settings several times and no avail. Somehow for a strange reason when making a call data turns on to 3g and the H+ but no LTE. I tried surfing the web and viola but as soon as I hang up data is gone. These are my settings as of now. If any of you have this phone on metro and have data working please help. Thanks in advance.

    Name
    Metro PCS (don't think it matters tho)
    APN - fast.t-mobile.com
    MMSC - http://mms.msg.eng.t-mobile.com/mms/wapenc
    APN type - default,mms,supl
    tastytoast likes this.
    05-28-2015 08:28 AM
  2. jpr's Avatar
    I'm not with Metro but see if changing the MMSC to the one in this thread helps. Metro Pcs / TMobile 4G or LTE Not Working , … | AT&T HTC One (M7) | XDA Forums
    05-28-2015 08:46 AM
  3. josearmz10789's Avatar
    Tried those APN settings jpr and it would only get me as far as 3G and H+ but the phone had to be changed to 2G/3G in the settings. After awhile they were gone and I switched the settings to 2G/3G/4G and it kinda worked. After some digging here in the forums this is what worked for me. Thanks to ambassador Rukbat for posting this.

    Try this as your APN settings:

    Name: MetroPCS (this is just so you know which one it is - you can name it anything)
    APN: fast.metropcs.com
    Proxy:
    Port:
    Username:
    Password:
    Server:
    MMSC: http://mms.metropcs.mmsmvno.com/mms/wapenc
    MMS Proxy:
    MMS Port:
    MCC:310
    MNC:260
    Authentication tupe:
    APN Type: default,mms,supl
    APPN protocol:IPv4/IPv6
    APN roaming protocol:IPv4
    05-28-2015 08:52 AM
  4. tastytoast's Avatar
    I'm having the same problem. It was working for an hour after I was at MetroPCS having them install the SIM, but my data just stopped working.
    05-28-2015 03:43 PM
  5. tastytoast's Avatar
    Thank you josearmz. I copied your settings 100% and as soon as I switched to the new APN, 4G enabled.

    It's been working just fine for a good 15 min now. I'll update if anything else comes up
    05-28-2015 08:59 PM
  6. SublimeDime's Avatar
    Thanks! Worked like a charm, after 3 days of in and out (but mostly out) data. I'll let you know if anything changes.
    05-30-2015 10:17 AM
  7. PhyreRed's Avatar
    Thank you so much! It worked perfectly!
    josearmz10789 likes this.
    06-10-2015 09:01 PM
  8. josearmz10789's Avatar
    Just an update MMS were not working so if your MMS are not working try this and it should send MMS now.

    Name: MetroPCS
    APN: fast.metropcs.com
    Proxy:
    Port:
    Username:
    Password:
    Server:
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS Proxy:
    MMS Port:
    MCC:310
    MNC:260
    Authentication tupe:
    APN Type: default,mms,supl
    APPN protocol:IPv4/IPv6
    APN roaming protocol:IPv4
    313sasquatch likes this.
    06-12-2015 08:39 AM
  9. TeraAshley's Avatar
    I created an account just to thank you. I haven't been able to send or receive pictures in forever and had just given up. Came across this and all I had to change was the APN Type and it worked immediately.
    Thank you so much!
    josearmz10789 likes this.
    12-07-2015 02:37 AM
  10. TheLastHer0's Avatar
    Thank you so much. Recently bought a locked At&t lg g3 phone, unlocked it and had to call Metro switch over from my iPhone 4 to my lg but the 3g/4g wasn't working. I followed these steps and it worked but my phone didn't have APPN protocol and APN roaming protocol. Just an update to who come across this with the same problem. Hope this not not going to screw anything up.......
    01-20-2016 03:39 AM
  11. 313sasquatch's Avatar
    Thank you, Bought the phone at microcenter and then took in to Metro PCS corporate store to get setup. Man did I get ripped off. Paid 15 bucks just for them to get voice and text working. I had no data, but didn't realize it till after I got home. While searching up on it, came across this and fixed it in seconds. Turns out they put in the wrong APN. They had it as fast. t-mobile. com instead of fast. metropcs. com and then had to change APN protocol from just IPv4 to IPv4/IPv6. After making those two changes 4G works. My only question now is whether I can get 4GLTE or just 4G?
    02-08-2016 08:08 PM
  12. Eric D2's Avatar
    Tried this and still had to remove battery. Had already sent phone to factory with issues. Anyone got more ideas
    06-15-2016 11:12 PM
  13. Bonny Clyde's Avatar
    I have metro pcs its not your phone the company is throttleing you they do it all the time to millions if you stream they know say you get 15 mbs when you stream they drop it to 2.5 or 3 some people lower they know your going to call so they tell you ways to fix it but it wasnt messed up in the first play so as soon as they guyed you through the steps they ask you hows it now and you say great its because they hit the button to speed it up but they didnt tell you is there a timer set in a couple of hours or maybe a day then it slows it back down big scam then after you let them go you start to get scam calls every day wonder were that came from metro pcs the know your 8 digit password and your pets name hopefut you did use the same pet and password on other sites or for a cc becease they aready know your birthday your mothers maiden name probly
    03-16-2018 05:57 AM
  14. Bonny Clyde's Avatar
    Keep changing to t mobile and back to default each time it gets slow and start a vpn
    03-16-2018 05:58 AM
  15. Bonny Clyde's Avatar
    That one slows down all the time
    03-16-2018 06:03 AM
  16. ckl171's Avatar
    Just used these settings to fix a data issue after switching my metro service to an old verizon samsung galaxy s5. It worked! Thank you!
    10-27-2018 06:47 AM

Similar Threads

  1. Replies: 1
    Last Post: 05-08-2016, 02:35 PM
  2. galaxy s6 not getting push notifications from fb
    By rbk4fun in forum Ask a Question
    Replies: 2
    Last Post: 06-01-2015, 02:32 PM
  3. Why is my Droid Razr M is not charging ?
    By De Shaikh in forum Ask a Question
    Replies: 1
    Last Post: 05-28-2015, 09:17 AM
  4. How do I know if the SD card is present or not through Android code/API?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 05-28-2015, 06:56 AM
  5. How to type does not equal sign?
    By AC Question in forum LG G3
    Replies: 1
    Last Post: 05-28-2015, 06:14 AM
LINK TO POST COPIED TO CLIPBOARD