1. Gerd Blasius's Avatar
    I just got my new zenfone 2. there is a lot of stuff not really working as I expected it. I used to have a Nexus 5 until I dropped it.
    Now LTE not working at my house makes me a little unhappy. However I get 4G service in town. At my house it says E in the icon.
    Anybody knows a cure.
    08-03-2015 11:31 AM
  2. Almeuit's Avatar
    It sounds like the radio can't hang onto LTE at your house like your previous phones. You may be able to snag a booster from them if you wanted.
    srkmagnus and Laura Knotek like this.
    08-03-2015 11:36 AM
  3. Jaysus's Avatar
    idea if it will help you, but it helped me recently, but try this: Settings/More/Cellular Networks/Toggle on Data Roaming (I think the default is off) It shouldn't help if you are getting Edge, but it may.

    Also, do you have a case on the phone? It may be in my head, but I seem to think I get better coverage in some spots with my case off.
    08-03-2015 03:37 PM
  4. srkmagnus's Avatar
    I agree with Almeuit. The device is picking up and holding LTE differently than your previous device. This type of thing often happens since devices are made differently. Such small things as placement/design of the antennas could impact connectivity to cellular/data services from one device to another.

    Also take a look at the APN settings for T-Mobile. Here is a faq for the Nexus 6: https://support.t-mobile.com/docs/DOC-17581

    The information should be the same for the ZF2.
    Laura Knotek likes this.
    08-04-2015 09:57 AM
  5. barkway's Avatar
    Got mine today too and I'm also TMo. Can't even detect my SIM card but I suspect that has to do with the system update the unit performed as soon as I turned it on (after all the initial setup). Going to call ASUS tomorrow. Oh and just a new user whine: really not pleased with how difficult it is to remove the back cover.
    08-06-2015 08:41 PM

Similar Threads

  1. Dialer is working properly in Nexus 5 Android 5.1.1
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-04-2015, 07:48 PM
  2. PIN attempts do not match actual entries
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-03-2015, 01:53 PM
  3. Replies: 1
    Last Post: 08-03-2015, 11:48 AM
  4. How do I remove the security lock on my phone?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-03-2015, 11:42 AM
LINK TO POST COPIED TO CLIPBOARD