1. AC Question's Avatar
    Whenever i tried to turn it on it vibrates but no logo appearing. What should i do?
    08-10-2015 10:02 PM
  2. asus_usa's Avatar
    Please ensure to use genuine ASUS AC adapter/USB cable. Please check if cable is firmly connected and charge for several hours. Please also try connecting to PC to see if its recognized. Have you tried booting into Fastboot mode? 1. When device is off, press (also hold) volume up key and then press (also hold) power key. After the device vibrates, release power key (keep holding volume up key) to enter Fastboot mode, please also see ASUSTeK Computer Inc. -Support-

    Sincerely,
    ASUS_USA
    cl-frank@asus.com
    Lord Mosh likes this.
    08-11-2015 07:27 PM
  3. Daniel Plazo's Avatar
    Same here..
    Nothings happen any more.
    10-15-2015 07:16 PM
  4. asus_usa's Avatar
    Dear All,

    If the unit can no longer power on after above troubleshooting methods have been performed then it will require warranty service. If located within the USA or Canada and would like RMA assistance please feel free to contact me direct at cl-frank@asus.com.

    For all other regions please see the following support page: Support Center | ASUS Global

    Sincerely,
    ASUS_USA
    Laura Knotek likes this.
    10-15-2015 08:01 PM

Similar Threads

  1. Replies: 1
    Last Post: 08-11-2015, 05:37 AM
  2. Replies: 1
    Last Post: 08-11-2015, 02:42 AM
  3. How do I change out my sim card on my g9006w?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 08-11-2015, 02:25 AM
  4. Replies: 0
    Last Post: 08-10-2015, 09:46 PM
  5. Replies: 0
    Last Post: 08-10-2015, 09:29 PM
LINK TO POST COPIED TO CLIPBOARD