1. TuesdayVisitor's Avatar
    I have the Asus Zenfone 2 ze550ml, since August 2015. I love it, great phone...blah blah blah.

    I've had Tmobile service (switched from MetroPCS) since February. When I first switched I was getting H+ speeds and my speedtest app was saying I was getting 25mbps. 2 weeks ago, I stopped getting the H+ symbol and now only get 3g. The 3g speeds are TERRIBLE! .33 Down and .4 up. I've contacted Tmobile NUMEROUS times and they all give me the run around and put in a "ticket" with the promise that they will call me back in 3 days with an update.

    The last person told me that they may have updated their towers and since I'm using a "world" phone (her words) it no longer works with Tmobile. I showed her my phone's specs to prove that my phone is, in fact, 4g compatible with Tmobile, and she quickly rushed me off of the phone.

    I live in the middle of a large city, in the middle of a huge coverage zone. I'm at a loss of what to do next. I love this phone, and I don't think I should have to buy a tmobile phone to get network data. I've changed, reset, double checked all of my APN settings and I still can't get better than this garbage 3g.
    04-05-2016 01:01 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Which APN are you using? Make sure it's the T-Mobile GPRS (fast.t-mobile.com) one.

    When you say you reset, do you mean you did a factory reset of the phone, or was that in reference to the APN?
    04-05-2016 01:12 PM
  3. TuesdayVisitor's Avatar
    fast.t-mobile.com

    I have no factory reset the phone, just the APN
    04-05-2016 03:29 PM
  4. TuesdayVisitor's Avatar
    What REALLY makes me angry is that, when I had service through MetroPCS, I had no data issues. I moved to TMobile because I thought I would get better quality with my phone calls. I'd much rather have good data and crappy phone calls. MetroPCS is a prepaid service that utilizes Tmobile towers, so I honestly don't know what the deal is.
    04-05-2016 03:41 PM
  5. B. Diddy's Avatar
    Try wiping the cache partition: New Steps to Wipe Cache in Zenphone 2-ZE551ML. If that doesn't help, it might be worth trying a factory reset.

    Also, ask T-Mobile for a replacement SIM card. If that works, then I'd ask them to refund the cost of the new card, since in that case, the previous card they gave you must have been defective.
    04-05-2016 10:14 PM

Similar Threads

  1. E:zlib memory/data/corruption error failed:No such file or directory?
    By Nikkei Gupta in forum General Help and How To
    Replies: 1
    Last Post: 07-04-2016, 11:44 AM
  2. Why is there a problem communicating with Google servers?
    By AC Question in forum General Help and How To
    Replies: 3
    Last Post: 05-01-2016, 09:04 PM
  3. Is there a way to connect my Apple Watch to an S7?
    By AC Question in forum Samsung Galaxy S7
    Replies: 4
    Last Post: 04-05-2016, 09:38 PM
  4. Replies: 1
    Last Post: 04-05-2016, 11:16 AM
  5. I have a problem with the screen
    By Cranedrio in forum Sony Xperia Z3
    Replies: 0
    Last Post: 04-05-2016, 09:12 AM
LINK TO POST COPIED TO CLIPBOARD