1. nilesh8582's Avatar
    I brought Asus Zenfone Selfie [Asus_Z00UD] in October 2015. [32 GB, 3 GB memory]

    I have been experiencing problems with charging for the past 2 months. I changed chargers and it used to charge for sometime. However, later I had to remove the battery each time before i could charge

    But now even the battery removal trick doesn't work. The phone won't charge with multiple chargers/ electricity points / computer USB. I have plugged it to a power source and its stuck at 18% with no increase/decrease in the charge percent. Worse there's no charging symbol appearing on the phone.

    The phone is using Android version 5.0.2 and the build number is WW_1.15.40.1582_20160510

    Any help on this will be much appreciated!!
    06-25-2016 10:29 AM
  2. B. Diddy's Avatar
    Have you tried a new or different battery? If that doesn't help, then I'd contact ASUS and ask about warranty repair--it should still be under warranty.
    06-26-2016 01:59 AM
  3. nilesh8582's Avatar
    i haven't tried a new battery as the phone is still under warranty. Taking it to an Asus service center on Monday.
    06-26-2016 09:54 AM
  4. B. Diddy's Avatar
    That should be fine--but if you can find a replacement battery for cheap, and if that works, it would save you the hassle of being without your phone for several days while ASUS examines it.
    06-26-2016 12:01 PM

Similar Threads

  1. Faster charging
    By snoozeys in forum Samsung Galaxy Tab S2
    Replies: 8
    Last Post: 06-25-2016, 04:05 PM
  2. Replies: 2
    Last Post: 06-25-2016, 10:24 AM
  3. Asus Zenfone Selfie doesn't charge
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-25-2016, 04:00 AM
  4. How do iknow when mohie is off and fully charged?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-24-2016, 10:27 PM
  5. Droid maxx boot loop and not charging?
    By AC Question in forum Motorola Droid MAXX
    Replies: 1
    Last Post: 06-24-2016, 09:03 PM
LINK TO POST COPIED TO CLIPBOARD