1. Mirski's Avatar
    A friend gave me this tablet to fix. He said that it won't download apps from google play. I decided to test it out and downloaded an app which after downloading and "installing" for a little bit gave me an error 504. My internet connection is fine, I can download apps on my phone just fine (OnePlus One) but for some reason they won't download on the tablet. I tried factory resetting multiple times with no success. I also tried downloading an apk from the internet and when i tried installing it it said "app not installed". I think it's the stupid "Zen UI", I think I'll try flashing a custom ROM on it as a last resort but before I do it is there anything you can suggest? Worst case scenario, what ROM would you recommend for that tablet?
    02-04-2017 11:34 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! You've also tried this on multiple different wi-fi networks as well, correct? Are you using your own Google account, or his?

    When you have a chance, head over to the Intros forum and tell us something about yourself! Introductions - Android Forums at AndroidCentral.com
    02-04-2017 07:46 PM
  3. Mirski's Avatar
    I haven't tried on a different network, but assuming he has the same problem and I can download apps on my phone just fine, I don't think it's the network. I am using my personal google account, but when he first gave me the tablet he was logged into his account and I got the same error. I also tried clearing data and cache on google play services and some other apps which I can't remember multiple times with no effect.
    02-05-2017 10:53 AM
  4. B. Diddy's Avatar
    It's possible for one device to work on a given wi-fi network, and another to have issues, so it's still worth trying a different network. Also, try rebooting your router (by unplugging its power for 10 seconds, then plugging back in).
    02-05-2017 09:23 PM
  5. Mirski's Avatar
    Ok, I tired this and unfortunately it didn't work. I also tried downloading an app with my mobile data connection (which is actually faster than my WiFi strangely) and it also didn't work. Thanks for your help though if you know anything else let me know. I'm starting to think more about flashing a ROM on it (since it's pretty slow even after resetting it), can you recommend one?
    02-06-2017 11:15 AM
  6. B. Diddy's Avatar
    Does it work in Safe Mode? How to turn on safe mode on Asus ZenPad 7.0 Z370CG
    02-06-2017 01:47 PM
  7. Mirski's Avatar
    Same result, something interesting I've noticed is that every time I reboot the tablet, the "optimizing apps" screen shows up and does the "optimizing", as if I updated the software.
    02-08-2017 10:57 AM
  8. B. Diddy's Avatar
    Flashing a ROM (or at least reflashing the stock ROM) might be a good idea, because it's starting to sound like the firmware got corrupted somehow. Sorry, but I don't have any direct experience with that, so I can't give you good recommendations. Check the forums at XDA-developers.com, or perhaps the Zentalk forums (the official ASUS forum).
    02-08-2017 05:33 PM
  9. Mirski's Avatar
    Ok, thanks for the help! Take care.
    B. Diddy likes this.
    02-09-2017 09:30 AM

Similar Threads

  1. Anyone using Extreme Call Blocker app?
    By 1countryboy in forum Android Apps
    Replies: 3
    Last Post: 07-03-2018, 03:36 PM
  2. Replies: 3
    Last Post: 02-14-2017, 07:42 AM
  3. Is whone app malware
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-04-2017, 11:13 PM
  4. Can't go in recovery mode
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-04-2017, 05:31 PM
  5. Replies: 0
    Last Post: 02-04-2017, 07:51 AM
LINK TO POST COPIED TO CLIPBOARD