1. AC Question's Avatar
    I just got my new watch. then i got my phone. i pared them up and within 30 seconds, on my watch a Google play service error. then another com. Google. something pops up to. every time i factory reset it or do stuff with Google play service like resting it or uninstalling updates or do what other people say on line it still pops up, i don't know if its trying to update or something like that, its just weird.

    my phone is on 5.0 and its a BLU Studio c 5+5
    09-24-2015 04:31 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! You have the Android Wear app installed, right? I wonder if there's some problem with the firmware on that phone that is causing conflicts.
    09-24-2015 04:48 PM
  3. Richard Servello's Avatar
    I have a Microsoft band, an Asus Zenwatch, and a moto 360. The 360 and band rarely, if ever disconnect. The zenwatch disconnects if I get over 10 ft away from it and often if my phone is in my pocket and my watch on my wrist. I think it had a cheap Bluetooth radio.
    PlanetPluto7 likes this.
    10-05-2015 07:12 PM

Similar Threads

  1. Replies: 40
    Last Post: 10-01-2015, 12:24 PM
  2. Replies: 5
    Last Post: 09-25-2015, 09:38 AM
  3. my head phones are not working
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-24-2015, 04:49 PM
  4. S6 Edge phone case
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-24-2015, 04:29 PM
  5. Replies: 0
    Last Post: 09-24-2015, 04:26 PM
LINK TO POST COPIED TO CLIPBOARD