1. chicagojimmyjames's Avatar
    Hi all.

    I am here to grovel at the feet of technophiles and beg for advice.

    I have a Motorola Atrix 4G phone, almost 2 years old (bought it when they first came out). I am running gingerbread 2.3.6 I think, and have had NO trouble with it for 1.5 years. Lately, lots of problems, getting worse daily.

    The phone is unlocked and rooted (that was done by me. It's a canadian phone but I used it for a stretch in the states) and although I thought I had done it correctly, one program recently told me it wasn't completely updated after being rooted. anyway: new problems:

    1. Wi-Fi won't work. In fact, the icon that toggles wifi on and off keeps disappearing from my home screen. Too many attempts to turn on the wifi through the settings menu will reboot the phone.
    2. It's freezing up doing little things, like emailing a picture (no problems until now)
    3. Random reboots, perhaps 2 times / day.
    4. Speaking of pictures, I can can take pictures, but they don't record. I get only blank squares, which then cause the phone to freeze up if I try to look at them or delete them.
    5. HUGE battery drain. From 100% to 50% in under an hour. At first I thought it might be time for a new battery, except the phone gets seriously hot, which makes me think it's running the processors overtime. Have no idea what it's doing, since there is no wifi signal. Almost all updates are set at "manual" and email is also manual. I have very practical apps, no games.

    And my BIG problem:
    6. since I can't get wifi to work (and apparently it's not rooted properly) I can't update to android 4.0. I'm kinda stuck. How to proceed? Any advice would be great.
    01-14-2013 05:42 PM
  2. chicagojimmyjames's Avatar
    OK... more information.

    My phone was properly unlocked and as far as I can tell it's rooted properly. I downloaded all of the java & android dtks, RSD lite, and the adb and fastboot stuff as well. Redid everything according to instructions here and on a few other forums. No problems. testing the connection throws the device id and the unique id back at me... so all of that went well.

    I have tried to flash some new roms, but I'm doing something wrong with the code because they won't go though, even though my pc definitely recognizes the phone when plugged in. So then I tried with a ROM manager app to get CyanogenMod, but it keeps blocking me out of "prvileged" functions.

    What gives? How can one program say I'm rooted and another say I'm not?

    Still no luck with the photo issue I mentioned above, although the WiFi suddenly (and mysteriously) has decided to work.

    Well, thanks if anyone can help.
    01-15-2013 01:13 AM
  3. chicagojimmyjames's Avatar
    Hey people -- a solution.

    I left my phone at the store for 3 hours today, but they had no luck fixing it. Said to bring it back in a few days when the "expert" would be around.

    Luckily, a little more tinkering and I got it to work.

    For anyone else with the Atrix who might be having similar problems, this is the page that had the working procedure.


    Now my wifi works fine. Can't imagine why that should go on the fritz, but there you are.
    01-15-2013 06:06 PM

Similar Threads

  1. Hello! Noob here with lots of random problems (and one big one)
    By Scryer360 in forum Verizon HTC Thunderbolt
    Replies: 1
    Last Post: 10-18-2012, 09:15 AM
  2. Need to return to stock but have a bunch of problems
    By mrwashy#AC in forum Thunderbolt Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 11-06-2011, 09:28 PM
  3. The Big One and The Little One
    By Heifzilla in forum ASUS EeePad Transformer
    Replies: 2
    Last Post: 07-25-2011, 06:48 PM
  4. Lots of little or couple big problems?
    By fooshii in forum Incredible Rooting, ROMs, and Hacks
    Replies: 7
    Last Post: 03-15-2011, 01:11 PM
  5. Replies: 7
    Last Post: 02-01-2011, 11:25 AM