1. seafoodlover88's Avatar
    Signal is inconsistent. I'm not talking about the bar since a lot of carrier phone don't have honest bar. I'm talking about the signal strength. I have extremely fast data connection on my old Note 3 but when I'm using this Axon 7, my connection speed is barely faster than my home internet which is barely faster than dial up. But that not the only problem. I went down to a place with extremely good T-Mobile signal and got a full bar on my phone yet I can't even watch a whole Youtube at 720p without buffering? We are not even talking about 1080p or 1440p resolution here.

    This is my only beef with this phone cause I love everything else about it.
    09-19-2016 01:07 PM
  2. TANDC's Avatar
    With TMobile Arizona no issues here wifi or cell connection
    09-19-2016 01:11 PM
  3. erasat's Avatar
    Signal is inconsistent. I'm not talking about the bar since a lot of carrier phone don't have honest bar. I'm talking about the signal strength. I have extremely fast data connection on my old Note 3 but when I'm using this Axon 7, my connection speed is barely faster than my home internet which is barely faster than dial up. But that not the only problem. I went down to a place with extremely good T-Mobile signal and got a full bar on my phone yet I can't even watch a whole Youtube at 720p without buffering? We are not even talking about 1080p or 1440p resolution here.

    This is my only beef with this phone cause I love everything else about it.
    Have you done today's update? If not check in Settings-Updates to see if your phone is ready for the OTA and do it, it seems to have fixed most of people's concerns about connectivity. After you complete the update go to Settings-Storage and clear Apps cache, then turn it off and Press Volume up and power buttons until you see the ZTE splashscreen to enter Recovery Mode, once there, do a Wipe Cache Partition and reboot.

    See if it's better.
    09-19-2016 02:47 PM
  4. seafoodlover88's Avatar
    Have you done today's update? If not check in Settings-Updates to see if your phone is ready for the OTA and do it, it seems to have fixed most of people's concerns about connectivity. After you complete the update go to Settings-Storage and clear Apps cache, then turn it off and Press Volume up and power buttons until you see the ZTE splashscreen to enter Recovery Mode, once there, do a Wipe Cache Partition and reboot.

    See if it's better.
    I did not know about that. I just got my phone on the 15th so I figure it is already up to date and I remember my phone updating when I first turn it on. If I do the whole reboot with the wipe cache partition and reboot, would everything on my phone be erase?

    Update: When I get to the splash screen, the moment I let go off the power and up button it goes back to the regular Axon screen so I can't do the whole reboot with wipe cache partition. Thanks
    09-20-2016 02:14 PM
  5. erasat's Avatar
    I did not know about that. I just got my phone on the 15th so I figure it is already up to date and I remember my phone updating when I first turn it on. If I do the whole reboot with the wipe cache partition and reboot, would everything on my phone be erase?

    Update: When I get to the splash screen, the moment I let go off the power and up button it goes back to the regular Axon screen so I can't do the whole reboot with wipe cache partition. Thanks
    The update was released Sunday night early Monday morning so if you got it on the 15th and didn't update it yesterday then just do the update via the settings menu.

    About the Wipe Cache Partition, no, doing this won't erase any settings or apps.

    Turn it off and press volume up first and don't let it go, then press the power button while keep pressing the volume up and in about 5 seconds you should have the ZTE splash screen and you can release both buttons and if done correctly it should enter the Recovery mode, just remember that you are doing the Wipe cache Partition not the Factory Reset.
    09-20-2016 06:44 PM
  6. seafoodlover88's Avatar
    The update was released Sunday night early Monday morning so if you got it on the 15th and didn't update it yesterday then just do the update via the settings menu.

    About the Wipe Cache Partition, no, doing this won't erase any settings or apps.

    Turn it off and press volume up first and don't let it go, then press the power button while keep pressing the volume up and in about 5 seconds you should have the ZTE splash screen and you can release both buttons and if done correctly it should enter the Recovery mode, just remember that you are doing the Wipe cache Partition not the Factory Reset.
    I figure it out. It actually made the phone slower. My download speed using my data was 2 mbps according to speed test, but now it like .50 mbps. Not sure why that is? In any case, both speed are extremely slow to be able to do anything other than basic web browsing. Do you have any other idea? I was so excited when other people said their signal improve but that not the case with mine. Thanks
    09-20-2016 07:01 PM
  7. ram1220's Avatar
    Have you done today's update? If not check in Settings-Updates to see if your phone is ready for the OTA and do it, it seems to have fixed most of people's concerns about connectivity. After you complete the update go to Settings-Storage and clear Apps cache, then turn it off and Press Volume up and power buttons until you see the ZTE splashscreen to enter Recovery Mode, once there, do a Wipe Cache Partition and reboot.

    See if it's better.
    No it didn't. All the update did is add more bars to the phone. There are even more people now in the ZTE forum complaining of poor cellular signals and poor download speeds. Myself included. I bought 2 A7's and both went back due to poor camera and extremely poor cell receptions.
    huntnyc likes this.
    09-22-2016 04:51 PM

Similar Threads

  1. Replies: 5
    Last Post: 09-19-2016, 03:54 PM
  2. How to turn Simon on a Microsoft Smart Phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-19-2016, 01:16 PM
  3. New droid z force says there was factory reset in phone info
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-19-2016, 01:07 PM
  4. Replies: 1
    Last Post: 09-19-2016, 12:56 PM
  5. Galaxy S5 - Why is my battery draining so fast?
    By unholymaster in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 09-19-2016, 12:30 PM
LINK TO POST COPIED TO CLIPBOARD