1. JonMark#AC's Avatar
    I have noticed that a lot of Widgets are not working ... from example, there are apps I've downloaded that I know have Widgets (Facebook, CNN, WeatherBug, Twitter, etc) that when I go to try to add the widget to my homescreen it is not on the list of available widgets even though I have the app downloaded. Not just with apps, but on actual Widgets such as SimiClock, it just wont show up in the list after I download it. Any reason why so many Widgets are unavailable? Using cm7 on SD card btw.
    12-12-2011 06:14 AM
  2. kcls's Avatar
    Have you moved the apps to the SD card? I know you are running CM7 from the SD card, but android doesn't know that. Widgets don't work on android unless the apps are on the "Internal memory" partition of the SD card, not the "SD Card" partition of the SD card, if that made any sense at all...

    You know what, just go to settings>> applications>> manage applications>> then click on the app, and if it says "Move to phone" or "Move to Tablet" or something other then "Move to SD Card" then click it, then see if the widget comes back.

    There, hopefully that made more sense.

    Tapatalkin it from my IHO CM7.1'd, ICS Themed Optimus V
    JonMark#AC likes this.
    12-12-2011 05:33 PM
  3. JonMark#AC's Avatar
    That did the trick! Awesome, thanks! ... I had apps going to the SD card since I only had that 1GB of internal storage to work with, I didn't wanna clutter it up with apps.
    12-12-2011 11:53 PM
  4. edriss's Avatar
    I know this is an old thread, but I cam accross it when the widgets on a BlackBerry Priv didn't work.

    Here is what worked. I went into >settings >apps an disabled all the apps that I had widgets of such bbm, Google search, Google news and weather, Music and then Clock.

    After disabling all of them, I restarted the phone and started enabling the ones I wanted and adding the widgets back starting with BBM and tested it work, then added music, it worked, then added clock it worked and then added the Google weather and news and it also worked.

    I think the clock app was the problem as last night there was a notification while I was doing something and I just hit a response without reading it!
    12-26-2016 04:44 PM