1. Andy_S's Avatar
    I have a rooted Nook Color that's been running great for months now, using CM7. However, on one of the recent updates, the Android Market and other Google apps stopped working. Several apps now have their icons replaced with a generic Android icon. I can't access:

    Market
    Calendars
    Gmail
    File Manager
    A few other random apps (REI, News & Weather, Wolfram Alpha, haven't tried them all.)
    In the ..../apps folder I don't see a Vendor.apk or anything similar.

    I tried rolling back to some previous builds which had worked for me, of course, but no dice.

    I am currently running ClockworkMod ROM Manager Premium 4.3.2.3
    ClockworkMod Recovery 3.2.0.1
    CyanogenMod-7.1.0-RC1-Encore

    Interestingly, maybe related, the "boot into recovery" option never used to work for me: it would just boot into Android, so I was using a separate SD to boot into recovery. Recently it started working properly.

    Is there an easy way to just shove the market and other Google apps back on there?

    Thanks.
    06-28-2011 10:18 AM
  2. jackchaos's Avatar
    have you tried the clear cache trick on the market app?
    Andy_S likes this.
    06-28-2011 10:51 AM
  3. Andy_S's Avatar
    Thanks for the response. I'm assuming the trick is Applications -> Market -> Clear cache. I just did that, and it made no difference. Market is version 2.3.6, if that helps. When I press the Market icon, the screen turns white, then it goes back to the launcher.

    Andy
    06-28-2011 10:57 AM
  4. Andy_S's Avatar
    Okay, I re-downloaded gapps.zip and installed it with Recovery. I then had to enter my account info again, and as far as I can tell everything is working.
    06-29-2011 01:17 AM
LINK TO POST COPIED TO CLIPBOARD